Brave not showing as Default Program in Windows 7

bug
windows
#1

Description of the issue:
I installed the new Brave but it is impossible to make it behave fully as default browser.
I did install it using Admin privileges, but that does not help. I did click the “set to default browser button” when launching Brave.

File mappings for .htm, .html etc were set to “Brave HTML document”, but Icons of files did not show Brave logo (no associated app). Double click did not work. When using Properties in Explorer, I set the Application to Brave. Now this at least works.

But clicking Hyperlinks still does not work. Clicking a link in Outlook results in error message "General failure. The URL was: http://xxxxx".

When opening Control Panel > Default Programs > Set your default programs, then Brave is not listed (the other installed browsers are).

In Control Panel > Default Programs > Associate a file type or protocol with a specific program I can see that the file types are now OK: like
“Name:.html, Description:HTML File, Current default: Brave Browser”

But when looking at the protocols section it shows:
“Name: HTTP, Description: Brave HTML Document, Current Default: Unknown application”

So for some reason it does not register correctly as an application. When using the button “Change program…” I can only select Internet Explorer and Firefox (the other 2 installed browsers". I cannot add Brave…

Steps to Reproduce (add as many as necessary): 1. 2. 3.
Did a complete unistall (also trashing the AppData folders and reinstalled as Admin. No success.

Actual Result (gifs and screenshots are welcome!):
See above in Problem description.

Expected result:
Well, clicking a hyperlink should work…

Reproduces how often:
Always

Brave Version(about:brave):
Version 0.59.34 Chromium: 72.0.3626.81 (Official Build) (64-bit)
OS: Windows 7 SP1 - 64 bit

Reproducible on current live release (yes/no):
yes

Additional Information:

0 Likes

#2

We have an open issue for this right now. If you read through the thread, you’ll see that some users have had success with a workaround for this issue:

0 Likes

#3

Thanks. Following the other thread I checked the registry key for

HKEY_CLASSES_ROOT\BraveHTML\shell\open\command

but that points to the right Brave.exe…

So that does not seem to be the issue.

0 Likes

#4

Thanks for testing for me.
We’ll have to look into this a bit deeper. Did you by chance upgrade from the Muon Brave?

0 Likes

#5

Yes. I had previously installed an older version of Brave. Not sure which version…

0 Likes

#6

Can you look in \AppData\local\ and see if there’s a brave directory there (not BraveSoftware, just brave)?

0 Likes

#7

There is no “brave” directory there. Only BraveSoftware.

0 Likes

#8

Do you have Brave set as your default browser in-browser? Settings --> Default Browser --> Make Default

0 Likes

#9

In settings it states: Brave is your default browser

I did another test: from a Hyperlink in MS Word I get different behavior than in Outlook. When clicking a link, it does activate Brave, opens a window, but displays the message:

Your file was not found
It may have been moved or deleted.
ERR_FILE_NOT_FOUND

in the address bar it shows:
file:///C:/Users/dvt/AppData/Local/Microsoft/Windows/Temporary%20Internet%20Files/Content.IE5/KQUWCZ6R/ENZDGNX6.htm

but not the link I clicked on…

0 Likes

#10

Click a link in any document works just fine for me using Win7. It looks like Brave is trying to open the file itself rather than the link you’re clicking on.

Can I see what the link looks like as it appears in your Word doc. or Outlook email?

0 Likes

#11

I did a few tests: links in Outlook, Word, Excel and good old Sticky Notes…

Sticky Notes: nothing happens when I click a hyperlink (no message whatsoever).

In Word and Excel I get the same behaviour:
2019-02-13%2009_17_32-Document1%20-%20Microsoft%20Word

When clicking on the link I get the following:
2019-02-13%2013_16_09-file____C__Users_dvt_AppData_Local_Microsoft_Windows_Temporary%20Internet%20File

Now the interesting thing is that the directory in the address bar does not exist:
C:/Users/dvt/AppData/Local/Microsoft/Windows/Temporary%20Internet%20Files

The message I get in Outlook is:
2019-02-13%2009_20_30-Microsoft%20Outlook

Thanks!

0 Likes

#12

Well, as I did not make any progress on this issue, I tried to install the beta channel release of Brave (first removed release version completely).
Version 0.61.34 Chromium: 73.0.3683.39 (Official Build) beta (64-bit)

It works fine now!

So apparently things were done in the beta version that fixed the problem.

Thanks for the help!

1 Like

closed #13
0 Likes