Expensify Login

#1

Hey,

Every time I try to log into my Expensify account, the website processes my login information, but then comes right back to the login page. I have tried to turn off the shield, same result. I have the latest version of Brave. I can only use this website with another browser it seems and Brave keeps bringing me back to enter my login info. every time I punch it in. Any thoughts?

#2

@WhiskyBear can you try with “Allow all cookies” via Brave icon at URL bar and see if it can solve your issue?

Thanks
:slightly_smiling_face:

#3

Hello @eljuno,

Thanks for your reply! I have tried all possible combinations, cookies/scripts/device recognition. Nothing seems to work :frowning:

#4

Hi WhiskeyBear!

Can you tell me what device you are using? I can try to help out with troubleshooting.

Thanks!
Steven

#5

Hello @steeven!

I have used Brave on all of these devices and the issue is the same, regardless of removing the Brave shield, but works normally on every other browser (safari, firefox, chrome):

I have tested this same website issue on an iMac 2015 with mac os 10.14 (up to date).
I have tested on a MacBook air 2017 running with mac os 10.14 (up to date).
I have tested this also on a MacBook Pro 2018 running macos 10.14 (up to date).

#6

Hi @WhiskyBear,

Thanks for the additional info! I haven’t been able to reproduce this on a 2017 Macbook Pro 2015 Macbook.

Would you mind PM’ing me some screen shots of what you’re seeing as you go through the login actions?

We will get to the bottom of this!

#7

Hello @steeven,

Here is a screen recording of the event. This recording was with Brave shield up (the behaviour is the same with the shield down). As you can see, every time I input the password manually or from my keychain, the page refreshes and the login didn’t punch through.

Thanks!

#8

@WhiskyBear,
When I tested on my end, I was able to login without issue. I know that you mentioned your recording was done with Shields up and that Shields down produce the same behavior, but would you mind showing and/or telling me what your Shields settings were for the site?

Additionally, can you click the “lock” icon on the left side of the address bar and share an image of what appears there as well?

#9

Hey @mattches ,

Thanks for following up! So this behaviour identified in the video occurs with shields up, shields down, and i have toggled different combinations of the shield down and up by enabling/disabling cookies/trackers/ device permission etc. No combinations or disablements have resolved the issue.

Hope that helps!
Thank you

#10

@WhiskyBear,
Can you try logging in using a Private window?

#13

Hey @Mattches,

So I was able to successfully log in normally with a Private window :thinking:

1 Like
#14

@WhiskyBear,
Thanks for testing – and that’s good news!
It’s likely a simple caching error which can be resolved by clearing your browsing data.
However, it’s likely an error specific to this site and not all sites – clearing site data for Expensify should do the trick. To do so (don’t worry, not as many steps as it seems):

  1. Visit Expensify and click the “lock” icon on the left side of the address bar
  2. Click Site Settings
  3. Scroll to the very bottom and click Reset Permissions
  4. Now scroll back to the top of the page and click the “back” arrow – this should land you in Content settings
  5. Go to Cookies --> See all cookies and site data
  6. Use the search box and run a search for expensify
  7. Click Remove All Shown to clear any remaining cookie data for the site.
  8. Relaunch Brave, visit and authenticate into Expensify.

If this does not work, you may want to try clearing all your browsing data.
You can clear any/all your data by going to Menu --> History --> Clear Browsing Data – ensure that the Cookies and Site Data box is checked.

Let me know if this resolves your issue or if any of the above is unclear.

1 Like
#15

Hey @Mattches,

Thank you so much, the issue is now resolved after following these steps. I really appreciate the time you took to note everything.

Thank you again!
Cheers!

2 Likes
#16

You’re very welcome!
Glad the issue was resolved. Please don’t hesitate to reach out should you have any additional questions or concerns.

closed #17