Brave prevents login to Ally Financial

Using Brave Browser v 1.36.119 on a Macbookpro running MAC OS Monterey v 12.2.1. When I enter my correct username and password and click ‘log in’ at Ally dot com, the Brave browser loads the next screen which is blank. Then the browser stops loading as if the action is complete. So I end up with a completely white screen with no messages. I can log in on other browsers using the same log in info. Any help would be greatly appreciated. Thanks!

@84eternal,
First thing I would do is update the browser as the latest version at the time of writing this is 1.36.122.

Next, I would suggest trying to login to the site with Shields down to test and see if that is the cause of the issue.

1 Like

My experience:

When I use with Brave, Ally has a 2-step page display (don’t know what to call it!) You have to allow scripts on the first page and then allow scripts on the second page also or all you will see is a white screen. By allow scripts, I mean you have to disable Scripts blocked .

2 Likes

Thanks, yes with Shields disabled I can log in.

Thanks, I tried Shields up with ‘Block Scripts’ disabled and it still would not allow me to log in…kept defaulting back to the login page. I found that in addition to having ‘Block Scripts’ disabled I had to also disable ‘Trackers & Ads Blocking’ and then set ‘Cookies Blocking’ to ‘Cross-site only’.

1 Like

Ah, nice that you were able to figure it out! I have “trackers & Ads Blocking” set to Standard and Cookies Blocking to Cross-site cookies blocked. I wonder if you could add ally.com to Sites that can always use cookies in brave://settings/cookies if you could turn Shields back on. Ally may already be there since you turned cookie settings off manually while on the site. Ditto for the javascript at brave://settings/content/javascript.
image

You should mark your above post as the solution. Really helps community members (and moderators I would think) when browsing topics to know which have been solved. :smiley:

1 Like

Thank you both for your assistance here. cc @fanboynz to see if there are any workarounds for this as well.

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.