Every other site cannot connect - Some are ok, most cannot connect to

In 2 days every other site can no longer connect. All other browsers are fine. It seems to be random, says check proxy. Not using proxy. Using AVAST antivirus, free version. Disabled Windows firewall - nothing has changed. Am getting fed up with this. Never happened before - just updated Brave to see if it would make any difference - and it hasn’t. Couldn’t even connect to THIS site and had to log on using another browser! Need help asap. Thank you.

Hello there
If you allow me to help you.
It is a problem of installation components. Could you tell me what brave you have, brave beta, brave nighfly, or what version you have.
Usually it is resolved in the restore point correction of your program.
On the other hand, it can also be the restore point of your computer, but if that is the case, you should save through an external storage drive, just to prevent your files from being erased. I also recommend that you save or write down your passwords or users if you are one of the people who save that information in the browser.

  • If you restore the point in your operating system, it will be solved. without having to install all your programs (windows performs restore points periodically) I don’t know what operating system you have.

Yes, it helped you or you have doubts about how to do the procedure, send me screenshots of your computer to know and guide you step by step.

This is the msg btw I’m getting: This site can’t be reached

The connection was reset.

Try:

ERR_CONNECTION_RESET

The version is
Version 1.30.87 Chromium: 94.0.4606.71 (Official Build) (32-bit)

I had no problems up to a few days ago. Nothing was done to the computer that I’m aware of and have no Windows updating permitted. I don’t know if I can even restore at this point. It’s useless when everything is else is working fine - EXCEPT Brave.

What version of Windows are you running?

Check and see if it’s this underlying issue.

7 please tell me there is another way around this other than downloading more windows updates - when all my other browsers are working no problem…

SSL certificates expire. It’s a fact of life in the world of encrypting communications to web sites. IF you are hitting this same issue, then yes, the correct fix is to install updated CA certificates, and the same problem did affect other browsers. Chrom*-based browsers (including Google Chrome) rely on the operating system’s certificate store. Firefox has its own, which would also have had issues, except Firefox updates (instead of OS updates) deliver new ones when required.

There is a very targeted resolution here: NET::ERR_CERT_DATE_INVALID Error on All Sites - #26 by Barnycc

This all assumes you are having the same underlying problem as others in that thread. If you temporarily disable Avast and try one of the sites again (such as this one) you should more clearly be able to see if it’s the same problem. If it is, then you have the answer above. If it isn’t, then we can start from there when we know Avast isn’t masking the underlying issue.

1 Like

Thanks for replying, I did disable Avast - same thing. I just clicked on that Certificate link in the resolution you posted, Windows tells me it’s already installed. Should I or shouldn’t I go ahead anyway?

I don’t know if this was conveyed, but it happens randomly - in about 30% of all the sites I go to. Other times it’s fine. Would really like to know why Brave is forcing people to update Windows and alternately, I’m pretty sure I’m not the only one who is facing this is issue and if there is any kind of workaround that doesn’t necessitate any Win updating. Interestingly, this all happened after Brave updated itself.

Thanks for testing that. It’s still hard to rule it out, because I’m not sure how extensive Avast will easily let you disable it. But let’s try something:

  • With Avast disabled, what is the exact error you get in Brave (when it does happen)?
  • With Avast disabled, what happens if you go here in Brave? https://expired.badssl.com/
  • Are the two errors the same? And in any case, can you include small screenshots of each?

To answer your other questions:

  • The seemingly ‘randomness’ of the issue, if it’s the problem that I think it is, is somewhat commonplace because you may connect to servers that have the newer certificate (which your computer may not recognize) installed on them, and some that don’t.
  • Again assuming it’s the above issue, technically ‘Brave’ isn’t forcing anything. Your computer in this case would have outdated certificates on it, and normally the new ones are delivered via Windows Update IF you have a current, supported operating system. If I understood you earlier, you are running on Win7; and especially if you have Windows Update disabled (among other security problems you may end up with as a consequence) then your computer won’t be kept up to date as the world moves on and old certs expire, and newer ones are issued. Chromium-based browsers, for better or for worse, rely on the operating system’s certificate database to assess which on the Internet are valid, or not. As mentioned, Firefox does this differently by delivering their own cert DB along with updates to the browser. Chromium may change to this model in the future, but it doesn’t work that way today.
  • You are not the only one having the issue, tons of people had this same issue – with Brave, Chromium, Chrome, and probably other browsers as well. Hypothetically speaking, I imagine if you were a Firefox user and disabled Firefox updates for some reason, I think the same problem would occur there.

It could turn out to be a completely different issue though, so the exact error messages from the two tests above will be critically important.

As a tangential aside, I would generally strongly recommend against disabling OS updates, as this will increase and prolong your security vulnerability as time goes on; and you may run into compatibility issues as well. Sooner or later various apps will just stop supporting out of date OSes.

Thanks again for replying

1 - This is the message I get when I disable Avast:

Your clock is ahead

A private connection to ----- can’t be established because your computer’s date and time (Sunday, October 31, 2021 at 6:00:15 PM) are incorrect.

NET::ERR_CERT_DATE_INVALID

2 - Same error msg with that site - Your clock is ahead

A private connection to expired.badssl.com can’t be established because your computer’s date and time (Sunday, October 31, 2021 at 6:01:45 PM) are incorrect.

NET::ERR_CERT_DATE_INVALID

Yes - they are the same - copied and pasted - hope that’ ok - Time on PC is correct.

Hope this sheds some light - much appreciated, points and recs noted, will have to sort things out with Windows - just don’t want to make things worse than they already are. Hopefully I can resolve things soon.

OK, great. Thank you for keeping an open mind about this. It’s probably a 99+% certainty then that the above is your issue.

I think if you use the instructions in that link to update your local certificates it should solve things. Note that further down on that page there’s also a YouTube video that someone posted, that demonstrates it. And there’s also a set of instructions for exporting from Firefox, if you have it installed, and then importing into Windows, if you’d prefer to do it that way vs. downloading directly from Let’s Encrypt. Either way should get you to the same result though.

If you can get past the issue with Avast disabled, then I think the odds are good that you’ll be in good shape with it re-enabled also, but if not then that will be a separate issue to tackle (probably thru Avast support somehow).

1 Like

OK - I’m heading out to uncharted territory - will let you know, hopefully next time from Brave and not Palemoon. Thank you so very much for your patience and lending your know-how in helping me fix this. Here’s hoping it works!

1 Like