Getting "Your connection to this site is not secure" for every single login attempt

Description of the issue: Just as background info, this problem didn’t start until after Windows did one of it’s forced updates this morning. My theory is that it caused the issue by trying to muscle out any browser other than Microsoft Edge.

How can this issue be reproduced?

  1. The following happens no matter what search I enter into the browser

  2. When I go to browse from Brave, every single search hangs up and gives the following message that pops up when I click on an exclmation mark (instead of the lock icon) that appears next to the web address in the search box: “You should not enter sensitive information on this site . . . because it could be stolen by attackers.” This can’t possibly be true, right?

  3. In the meantime, it tries to load, but then it times out, and I get this message (I just used msm.com for an example. I get the same response no matter what web site I try to visit):

www.msn.com took too long to respond.
Try:

  1. I’ve tried uninstalling and reinstalling Brave, but no change.

  2. I’ve tried Brave’s “Resotre settings to original defaults” , but no change.

  3. I’ve tried turning the computer off and on after every change made, but it made no difference.

Expected result: I’m hoping that I’ll be able to start using Brave to browse again. I reeeeeally don’t want to be forced to use Microsoft Edge, becaue it works flawlessly on my computer.

Brave Version( check About Brave): 1.45.123

Additional Information: Thanks in advance so, SO much for your help!

Can you turn on this option in Brave settings:

image

And then cause the issue to occur again, and add a screenshot that includes the error as well as the URL bar?

Hi, JimB1.

Thanks so much for responding to my SOS. I have no idea how or why, but the day after I posted the problem everthing just started working again. My apologies for not making that known sooner.

All the best,
Laurie