Error code 3: [0x80040154] when updating

When checking for updates I’m receiving “(error code 3: [0x80040154]” and have not been able to figure out way around it.

I’ve uninstalled Brave, rebooted and reinstalled to no avail. This has included deleting any folder on the computer associated with Brave and deleting any registry entries, that I can find, related to Brave.

Running Windows 10 with the Windows antivirus.

Thanks,

Dan

1 Like

@danohall,
There’s a small chance you’ll need to whitelist Brave in Windows AV as it may be getting blocked there.

Are you using a VPN or proxied connection of any kind? If so, please try disconnecting from the VPN and attempt to update again.

If none of the above works, you can try using the offline installer to get the latest build onto your machine (future updates, ideally, should work fine after this) — you can find the offline installer here:

Assuming you’re using a x64 system, you’ll probably want to use this one:

1 Like

Not using VPN or proxied connection. ISP is Comcast. Will try the offline installer

2 Likes

Let me know if it works for you — if not we can continue troubleshooting.

1 Like

Still getting same error code. Had uninstalled Brave, rebooted and installed the offline version. Still getting the same error code. Added Brave folder to the Windows Security allowed section but had no effect. I don’t get it. There has been a couple of times over the past couple of years that Brave wouldn’t update but after manually downloading the install file and rebooting, things worked fine…until the next time they didn’t. Now it seems to be broken, period. Just downloaded a Firefox update with no issues.

@danohall,
Thank you for the update. I’m going to reach out to the team for some more information on this — definitely shouldn’t be seeing the error any more. Hope. to have more information for you soon.

1 Like

The only other thing I’ve been able to find is that the Brave update services won’t start. I get this error message if I try and start them manually. Not smart enough to figure this part out.

Message

1 Like

@danohall,
Can you confirm the version number that you’re on presently? You can see this by going to Menu --> About Brave.

1 Like

Version 1.46.144 Chromium: 108.0.5359.128 (Official Build) (64-bit)
](https://brave.com/latest/)

1 Like

After multiple attempts at installing/uninstalling/reinstalling, it seems to be working.

Had the same error again, a few days ago, but uninstalling and reinstalling got rid of it. Not sure why this keeps happening.