Problems with Updating Chrome and Brave Error Code 3: 0X80040154 -- system level

Troubleshooting technical issues is much easier when both the user and support agent practice clear communication. For this reason, we have provided the template below for you to fill out with information about your issue. Please provide as much detail as possible so we can most efficiently resolve your problem.

Delete the any text above the line separator below before posting

Description of the issue:
How can this issue be reproduced?

  1. I go to Settings/About Brave to attempt to update desktop software on a new Win 11 PC
  2. A Windows UAC windows pops up and I click Yes to allow App to make changes.
  3. Then the update fails. The same exact thing happens for both Chrome and Brave.
  4. Yes this can be reproduced. Happens every time. Tried uninstalling Chrome and reinstalling it.
  5. Expected result is to get the latest version of Chromium, which from another PC I can tell is Version 107.0.5304.121
  6. Uploading screen shot of error message.

Expected result:

Brave Version( check About Brave):

Additional Information:

Could you restart the computer and try?
Maybe close all Brave & Chrome tasks in task manager.

@Mattches @steeven would be great if you guys take a look as well as I’m not sure about being exactly helpful about this.

Yeah, open task manager with Ctrl + Shift + Esc and kill all update processes related to Brave and try again.

1 Like

I tried closing all open tasks via task Manager. Not sure how to “kill all update processes”. Went thru all tabs on Task Manager and killed anything related to Brave, reopened Brave, Still getting same results. Is it normal to get a Windows UAC message when trying to update Brave? The good news is even though I get an error message from Brave, I believe it is updating my browser to the latest versions of Brave and Chromium.

NOTE: When I got this new laptop I used Laplink PC Mover software and that software installed Brave for me. Not sure if problem is related to that? I have not uninstalled and reinstalled Brave because Sync is not working for me either. See attached screen shot.

I have everything the way I want it on Brave with bookmarks and settings (except for update problem). Would like to be able to save settings via Sync chain, but will not let me do it for some reason. Not sure how I get the Keychain Access App for Windows 11 either … documentation only talks about for MAC users.
Separate issue, but would like help in how to do Sync when getting this error message.

Just End task all update-related processes like these in Processes tab, it has worked for me so far-

Also, better to download brave from instead of a third-party tool. You can download even now and it should apply the latest version.

Will have to tag @Mattches for this.

I only see the process for BraveSoftware Update when I do Settings/About Brave. As soon as I do that the Windows UAC permission window pops up. If I go to that windows and click yes to give it permission, then the above process disappears. I will ignore this for now because I think it is updating my Brave and Chrome browsers OK anyway.

QUESTION - what is the easiest way to know the latest version that I should have for both Brave and the Chromium when I do Settings/About Brave? I will just manually monitor it for awhile since I don’t think there is a fix to this.

You can track updates at

Easiest way to check the latest version is as @SmartyAadi stated — check the page.

As for your issue, can you please try re-downloading the installer and running it? Doing this will not overwrite anything as long as Brave is already installed on your system — it will only attempt to fetch and apply the latest updates.

Please let me know if this properly updates the browser.

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.