I have the following problem with Brave or Chromium based browsers. As soon as I establish a VPN connection on my Android, the following problem occurs. As soon as I open a link from another app, the browser starts and I often get an error “ERR_NETWORK_CHANGED”. The problem occurs only on mobile networks, not WiFi!

The problem can be reproduced if the filtering of ads and trackers is completely disabled in Brave. Also, Brave must be completely closed as a task.

Has anyone noticed this as well?

Hi there @bastele welcome to Community.

Are you still experiencing this issue?

Hello, yes, I still have the problem. Can you reproduce it? Can reproduce it by disabling the shield completely.

I have the same error but on macOS. I use Proton VPN, tested several settings. Also tried disabling other network adapters, but no luck. Safari and other browser are fine. Sometimes this also happens without VPN, so I would say its not specifically tied to VPN connections but problems of Chromium with latest security features of macOS and iOS like Mac Address and IP hiding.

I have created a ticket with the error. If you could also contribute a netlog, that would be great.