Brave Browser + UAE + VPN = Disaster [SOLVED!]

Description of the issue:

I’m currently in the UAE and Brave Browser is unusable here when paired with a VPN. Safari has no issues with VPN active. Can anyone shed some light into what’s going on? With VPN turned OFF Brave Browser functions and pages load quickly. With VPN turned ON Brave will take ages to load pages and sometimes load them partially or not load them at all. I also get ERR_NETWORK_CHANGED errors. Can anyone explain what’s happening and why this issue only affects Brave and not Safari with VPN in UAE? DNS settings, extensions and toggling shields settings have no effect regardless of configuration active, inactive etc. Loading a fresh instance of Brave with default settings also has no effect on solving the slowdown and malfunctions with VPN active.

Exact URL of the website in question:

All of them.

Did the issue present with default Shields settings? (yes/no)

Yes

Does the site function as expected when Shields are turned off?

No

Is there a specific Shields configuration that causes the site to break? If so, tell us that configuration. (yes/no):

No

Does the site work as expected when using Chrome?

Unknown

Brave version (check About Brave):

Latest

Turns out it must have been the router or ISP at the Air BNB I was staying at. I’m at a new Air BNB and Brave is working again using the internet connection here. I’m still puzzled as to why the router at the old place only affected Brave and not Safari but hey I’ll take a win when I’m given one.

2 Likes