Download error for no reason, I can´t download anything

Description of the issue:
Every time i want to download anything, as soon as it starts, it stops and gives an error

Actual Result:


(it says: “Error: Download error”)

The same thing happens with everything, be it audio, video, json file or whatever
.

Expected result:
That I download the files damn it

Reproduces how often:
Always, every time i download something

Operating System and Brave Version:

Version 1.45.118 Chromium: 107.0.5304.91 (Oficial Build) (64 bits)

Windows 10 pro (version 21H2)

Additional Information:
this only appears on my windows user, but in every Brave user

Are you using any extensions? If so, have you tried with them disabled?

Does the issue occur in a Private window?

Does the issue occur if you create a new profile and try it in that profile? (Make sure your original profile does not have any open windows; only the new profile should be open.)

I wasn’t sure what you meant by this. Do you mean you already have multiple browser ‘profiles’ and the same happens in each of them? (In which case, probably no point in creating a new one to test there.)

Is any antivirus or other security software (besides MS Defender) installed? If so, does anything change if you temporarily disable it?

I have no extensions, i tried on a new profile and on a private window and nothing worked, and no, i don´t have any antivirus

perhaps the firewall is blocking the downloads? IDK

Does this happen when you try to download any type of file, or is it specific file types? For example, if you were to perform an image search on your preferred search engine, then right-click and Save image as..., do you get this same error?

if you were to perform an image search on your preferred search engine, then right-click and Save image as... , do you get this same error?

Yes, it happens with everything i try to download

@Quantodeluz,
Very strange behavior, especially with no extensions and no A/V. Does changing your download location make any difference in the behavior? I’m wondering if you have it set to somewhere where the browser doesn’t have permission to write to (unlikely but worth a shot).

I’m also curious if you were to download and run our Beta build whether or not you would see this same issue. Would you mind testing this to see if you get the same behavior when using the Beta as well? Note that installing/running the Beta will not interfere with your current installation in any way.