Failed Download - Insufficient Permissions (FIXED?)

I have had brave for almost a year now, and I’ve never had this issue. I’ve not knowingly changed any setting in Brave or my Computers Operating software to cause this issue. But when I try to download any file to my SSD it claims there is insufficient permissions. But it allows files to be downloaded onto the same computer using the HDD. My Desktop is stored on my SSD and it will not allow me to put it into the downloads folder NOR the desktop.

Anytime I try to download a file is when this issue occurs.

  1. Image, audio, video, pdf, misc files.

I expect That my browser will be able to download to my SSD as it should.

Brave version:
1.42.86 Chromium 104.0.5112.81 (Official Build) (64-Bit)

My SSD is not full, has 100GB of free space.
I already tried to uninstall and reinstall.
Also tried restarting my computer.

1 Like

Can you create files in the same location manually?

Do you have the same issue with any other browsers?

I also experience this error after the last update (1.42.86), I’m unable to download, unable to upload, unable to use Vietnamese typing keyboard
Already tried the other browsers, still working fine
This is serious, @steeven please have a look at this

@Rofocale47 @HolyCoyote,
Can you both confirm whether or not your on Windows and if so which version (Win 10, 11, 7, etc)?

Yeah I’m on Win10 and I’ve just found out another bug, links does not open in Brave when I click them, even though Brave is set as default.

This build got so many bugs

Please open another thread for a separate issue. I’ve reached out to the team about the downloading issue.

1 Like

Glad I searched & found this before making a new topic.
I’ve had no problems til today.
Accidentally changed a setting on downloading images from a web search.

Firefox works fine, but I only get Failed- Insufficient Permissions from Brave.
I suppose a setting’s trying to be overprotective, so I can’t save any images.

Searched Help, and found no help. Only: cancel & try again, which does nothing.
Maybe there’s a way to give myself permission in a setting. Thanks.

Yesterday my brave updated, I use Windows 10. And I am unable to download my attachments even in email. I went to windows edge and was able to download it. tried closing my antivirus and reset Brave setting and even closed brave shield. non resulting any help.

But my file is having no problem to be downloaded via google chrome or microsoft edge. Please fix this at the earliest or I have to shift to another browser to continue work.

For folks reporting this issue here, can you please chime in with:

  • What is the folder path it’s trying to download to?
  • Are you running any antimalware/security software other than MS Defender?

And if the answer to the 2nd question is ‘yes’ does the behavior change if you temporarily disable the security software?

Hello, I also have the same problem. I have windows 8, I have been using the browser for 2 months and I had no problem, but since yesterday I have the same problem, I try to download something (image, video, pdf, etc.) but I get “Insufficient Permissions”

I am also having the same issue, using both the newest version of Brave and the Beta, I cannot download in either ‘normal’ or ‘private’ mode.

I did turn off my Avast AV, and was able to download, but as far as I can tell Avast has not updated/pushed a new version since July 21, 2022, and my downlaods were working fine until yesterday(ish), may have been the day before.

I also have the same issue. I can no longer save files to my desktop. The only way to fix this temporarily is to change download location from your desktop to another location. Go to settings and look for " Location". Click on " Change" . Change it to another location EX: downloads folder.
I know it’s kind of annoying but that’s the only way to save or download files.

Thanks for the response.
Desktop. Sometimes Pictures.
Not sure on Defender, but use Avast. Never had to disable security software & am not sure how. But never needed to for saving an image before.

Guess I’ll try restarting the PC today, and the Downloads location change.
May get lucky & solve the problem. Or get help from a person I work with. If all that fails, I can stop using Brave for image reference if there’s a temporary bug on changing permission for myself.

Well, I think we might be seeing a pattern starting to develop here (see above).

If you are using a paid version of Avast I would contact them and at least see how to temporarily disable it, as a test. And preferably also inform them that this is going on. Quite a few Avast-related issues showing up here lately I think.

I can’t explain ‘why’ of course but my guess is, they probably whitelist certain ‘major’ apps that are known to them, and if Brave is not in that whitelist due to not being as widely deployed as something like Chrome and FF, then it will be unfavorably discriminated against by their software.

I’ve been using Brave for about two years, give or take, and avast longer than that.

It wasn’t until this week Brave stopped working as it had been. It seems to me that if Avast had/has an issue with Brave, it would have happened long before this week?

Just to confirm, anyone here using Avast is using the desktop application and not the web extension, is that correct?

I am using the desktop app.

1 Like

Possible? Yes. Necessarily so? No.

The big thing to keep in mind is that both of these apps (Brave and Avast) are constantly changing. And depending on how their controls work, or whitelisting (if that’s how they’re doing it), it may or may not be written well enough that it ‘catches’ (in a good way) a new iteration of an app.

Or for that matter, they may have deployed a bad signature set. This may not even warrant a new ‘version’ on their side, but just a daily (or so) update to their signature database.

Happens with security software vendors all the time.

I could be wrong about all of this but we’ve got at least 2 users of the same combination just in this thread, possibly more, it is at least worth ruling it out, and it would take longer to debate it than it would to just test it and get to the next step and help the entire user base impacted by this.

Meanwhile I’m hoping others on this thread will also chime in whether they are also using Avast.

Edited to add: if others can also confirm that they are on Windows as well, that will help. We’ve seen a bunch of this happen on macOS for various reasons (filesystem permissions, as well as AV software) not too long ago, but the solution there could be different. So it’s important to focus on the right OS here, as this thread was originally tagged as Windows.

Some small discussion on Reddit as well:

So that’s at least 2 other users with the same combination of software (Brave + Avast).

Here’s someone a couple years back, having the same issue – unclear but presumably with Chrome:

Last comment here, same problem with 3 browsers:

Same problem with Opera, July 2021:

December 2017:

Use Avast! desktop app. Image downloads were failing due to “insufficient permissions”. Disabled Avast! shields temporarily using the icon in the taskbar. Everything worked as normal. Definitely the anti-virus causing some issues.

1 Like