Double-clicking icon doesn't open Brave browser window

When I try to open Brave, it only opens in the system tray. I can hover over the icon there and see the website, but I cannot open the browser window. Also, no matter how many times I try to close the program in the system tray, it still leaves one page there.
I searched for this issue and found this closed discussion:

I tried the solution that worked for this person, but it didn’t work for me.

@Roxi,
Can you please try opening the Windows task manager and closing any Brave related processes (open windows, updaters, etc) and then try launching the browser again?

Yes, I tried that too, but it changes nothing. I tried it again, just to be sure.

I just tried your suggestion and then the suggestion from the previous post (Windows icon + R, …) and it worked!

Have you downloaded Brave from places other than the official Brave website?

It could also be because your browser did not install an update correctly. I am certainly no expert, but it is not normal that the Browser only opens when it is from Windows + R

Also try to find out if you are using the latest version of Brave.

1 Like