My Brave Browser Stopped Opening Today

Description of the issue:

Brave stopped opening. It’s my default browser.

Steps to Reproduce (add as many as necessary): 1. 2. 3.

I click on the Brave icon in the tray or the desktop shortcut and nothing works. I can click either a hundred times and it doesn’t open up.

Actual Result (gifs and screenshots are welcome!):

Expected result:

Reproduces how often:

Operating System and Brave Version(See the About Brave page in the main menu):

Win 10 Should be latest version. Can’t open it to see.

Additional Information:

I read the other threads on this from 5 years ago, but nothing helps.

I would do an uninstall/reinstall but I can’t backup my logins and bookmarks since I cannot open Brave.

I have the same issue. I also tried some of the older tips to fix but nothing helped. Right clicking on the icon and checking the compatibility tab shows that it is only compatible up to Windows 8 and I am running Windows 10. This browser has always worked but not anymore on Windows 10 using the latest installer.

Disable all Windoze compatibilities.

Did that. Still doesn’t work.

@Prorec and @SenorPedro not sure if you’re both still having issues. But I’d like to have you try a few things here.

  • First off, can you both confirm with me whether this happens even if you go to https://brave.com/download/ and install it again? Just to be clear, I do not want you to uninstall your browser. By going there and downloading again, it will perform a manual update. This can sometimes repair any corrupt files.

  • If it still doesn’t launch after that, I’d like you to try to launch Brave as an administrator and see if it works.

  • If that doesn’t work, I need you to confirm if you have any firewall or antivirus/security programs on your device. If so, it’s possible that they are blocking Brave from opening. If you can disable those (just temporarily) and test, it might help rule that out.

  • Lastly, if above doesn’t seem to matter, can you try getting Brave Beta or Brave Nightly and see if it opens there?

Guess also want to confirm, is this only happening with Brave and not Chrome or any other browser?

Disabling the windows version compatibilities as described earlier fixed it for me.

When Brave started doing this I did download the latest version and installed it without uninstalling the current installation. Didn’t help.

I have tried multiple time to start Brave as administrator. No help.

Currently I have Windows 10 firewall and Defender as antivirus. This didn’t cause any problems before this issue. I checked the firewall and Brave is listed as allowed.

I will try Brave Beta and Brave Nightly. Should I uninstall my current Brave version first?

This only happens with Brave. Firefox and Chrome work fine.

Thanks.

No, absolutely no reason to do that. Brave Beta and Nightly just are future versions of Brave in testing and are standalone. So you are able to have all three downloaded and running separately.

Using them just helps to know if a problem being experienced is version specific

OK. I will try those versions. I am using the same version of Brave on a desktop computer and have no issues with it so it must be something on my laptop. Thanks.

1 Like

I installed Brave Beta and it works fine. Thanks for the help.

Open command Prompt and type the following

shutdown -s -f -t 0

Wait for your PC to turn off, Turn Your PC ON again,

Turn off Wi-Fi, Run this Script

Launch Brave after you Run the above Script and while Wi-Fi is OFF.