Brave does not open when desktop icon or quick launch icon or start menu icon pressed

Description of the issue: When I try to double click the icon to brave in the start menu, on the desktop or from the taskbar, Brave will not open. To open a Brave window, I have to use an existing window and middle click/right click open in new window on a link.

How can this issue be reproduced?

  1. Try to open Brave with desktop icon or quick launch icon or start menu icon

Expected result: Brave window opens

Brave Version: [Version 1.4.96 Chromium: 80.0.3987.132 (Official Build) (64-bit)]

Additional Information: This also happened to me when I used Chrome, I moved to Brave based on good reccomendations and This problem

1 Like

This tells me that your issue is system related somehow. Just my guess from what you describe.

What sort of system issue would it be? I can’t really think of any problem that would stop a browser opening, since everything else on my system works fine

Here’s a gif of what happens when I try to open brave/chrome

I tried reinstalling Chrome before I tried Brave, which didn’t help the issue

1 Like

I turned off Hardware Acceloration, and that seems to make it open from the places where it previously didn’t, but I’m sure it’s intermittened. I’ll have to keep an eye on this.

EDIT: This hasn’t fixed it, I still cannot open Brave via the methods mentioned

1 Like

To confirm, you’re saying that from the Start menu – that is, on Windows, Start --> Brave – the browser won’t launch?

:point_up: You shouldn’t have to double-click an item in the Start menu to get it to launch – do any other applications (outside of Chrome as you mentioned) behave in this way?

  1. What if you create a shortcut on your Desktop and attempt to launch it from there – what behavior do you see?

  2. Can you check C:\ProgramData\Microsoft\Windows\Start Menu\Programs and tell me whether or not you see Brave here?

1 Like
  1. Sorry about that, I misworded that, I single click for everything but the desktop. If i single click, the same thing as in the GIF happens for Brave, but not for Chrome at the moment.

  2. Same as 1.

  3. A shortcut to Brave is there, and does the same as 1.

EDIT: Even Chrome Apps that you can create via Burger > More Tools > Create Shortcut --> Tick Open as Window don’t open from their desktop shortucts, but do from brave://apps


1 Like

I have found that right clicking on the brave taskbar button and using open window/private window also does not work. Is this something to do with Windows Explorer?

We just released an update to v1.5.112 – can you try re-running the installer (you can re-download it here if you no longer have it) so the browser will fetch the latest updates? Note that running the installer will not overwrite any Brave data – if an existing installation is detected then the installer will simply fetch the updates and apply them.

1 Like

That worked! Thank you very much!

I rebooted the system, and it already stopped working. Sorry for getting your hopes up!
I’m back to exactly the same behavior as before. Works once, and never again.

I use a few of the “Open as Window” Shortcut apps, could they be any issue?

1 Like

To confirm, you don’t have any extensions installed in the browser at this time?
Additionally, are you using any system/cache cleaning apps, like ccCleaner or some other equivalent?

1 Like


  • UBlock Origin
  • Bitwarden
  • Google Translate
  • Google Docs Offline
  • Application Launcher for Drive
  • iCloud bookmarks
  • H264ify

I am not using any tools like CCleaner.

Can you try launching the browser from the command line using the following command (just open the cmd, type the command and hit enter):

"C:\Program Files (x86)\BraveSoftware\Brave-Browser\Application\brave.exe" -disable-extensions

Does the browser launch/stay open this way?

1 Like

Still the same unfortunately.


1 Like

I have the same issue. However when I restart my pc and open brave, no websites load up. Then the browser couldn’t be opened.

1 Like

At this point I’m not sure what could be going on to be honest. If you’re willing to, I think you should try downloading our Beta build and see if you’re able to launch and run the Beta without issue. It would help us isolate where the conflict is coming from (Brave vs your system).

Note that again, downloading/installing the Beta build will not overwrite any of your current Brave data – they will run in parallel.

1 Like

Hey Mattches,

The Beta works fine with all the ways i try to open in, even after restarting. I can’t test “right click on taskbar icon > new window” as the Beta doesn’t seem to have that feature.

I’m a bit lost on what to do now. I’ll have to see about fully reinstalling it, since i’ve already tried rerunning the installer even before the latest update.

I’m not particularly up to reinstalling my OS, etc

1 Like

Have you used any kind of hardening or privacy tools for the OS? Just a thought…

I haven’t purposely, and non of the software i’ve got installed should be doing anything like that. I’d say nope.

1 Like

I’d like to note that Task Scheduler seems to be able to open the App Windows fine, it’s just trying open Brave from it’s shortcuts.

1 Like

So the Beta works just fine as intended and the stable release won’t launch via any shortcut. Is that correct? You might want to try a completely fresh install of Brave – don’t worry, you can save your data. Try the following:

  1. In Windows, go to ~/AppData/Local/BraveSoftware/Brave-Browser/User Data
  2. Copy the entire User Data directory and make sure you save it somewhere safe
  3. Then use the Windows Add/Remove programs service to uninstall Brave. Make sure that you elect to delete any associated browsing data along with the uninstall.
  4. Re-download and run the installer.

Now try launching the browser from a shortcut/quick launch icon and see if you get the same results. If the browser launches as intended, all you need to do to get your data back is to go to the same directory listed above, and replace the newly installed User data directory with the one that you saved in the steps above.

1 Like