Disable autocomplete in address bar - BUT - keep autosuggestions on

Description of the issue:
I would like to disable autocomplete in the URL bar, but keep auto-suggestions on.

For example if I start typing a URL, I want the suggestions to appear below in the drop-down menu, but if I hit half way through typing the URL it should NOT auto complete the URL for me. If I want to use the suggested URL I should have to either hit tab then enter, press down arrow then enter, use the mouse, etc.

I have configured these settings:

  1. Settings → Appearance → “Show autocomplete suggestions on address bar” → ON
  2. Settings → Privacy and Security → “Auto-complete searches and URLs” → OFF

I thought configuring these settings should result in my desired behaviour, but it doesn’t. If I start typing a URL, it auto completes it for me, which is not what I want.

I think the second setting “Auto-complete searches and URLs” is broken, as I turned it off, but it’s still auto-completing my searches and URLs.

Am I misunderstanding what this setting does? or is it broken?

Brave Version:
Version 1.46.133 Chromium: 108.0.5359.71 (Official Build) (64-bit)

Yes, it seems you are mistaking things. So let’s review.

This means it will do what you’re saying you don’t want it to. This turned on means it will autocomplete what you go to type in your URL bar. So if you go to type goo it will autocomplete google.com or whatever.

Of course, you have your options there. For example, the check boxes in the screenshot below is where you can narrow down the type of content that is shown as autocomplete. I have Bookmarks and Suggested Sites off as I got tired of those, leaving it just to my Browsing History and Top Sites, though I occasionally turn off Browsing History too.

Settings - Privacy and security - Brave 12_22_2022 01_48_26

So yeah, depends on how much you want shown complete as you go to type things in your search/url bar. If you don’t want any auto complete, you’ll want it turned off completely.

This toggles whether you want data sent to your default search provider. So let’s say you’re using Google for your search. If you have this toggled On, then it will have some of the cookies on your device shared with it, so it might be able to guess better what you’re trying to type or so results might be more personalized for you.

So yeah, the first is about autocomplete in the browser, on the search bar. The other one is about whether you want to share cookies with your search engine.

I guess the desired behaviour I want is not possible then. :frowning:

I might post a feature request. Surely I’m not the only person who would prefer this. This behaviour is the standard if you just go to google.com, or duckduckgo.com homepage.

The annoying thing for me Is that I often search for things in this format:
" -Thing- -Question about thing-".
For example:
“brave browser how to disable autocomplete?”
then some time later I search for just the -thing- by typing:
“brave” and hitting enter without looking.
Then it auto-completes and re-searches what I searched for a month ago. Gets annoying.

Rant over,
Thanks anyway.

@AGuyUsingThisBrowser I mean, if you disable Show autocomplete suggestions in address bar completely, then it never will suggest anything as you type. So when you type thing it won’t show you anything else but thing. You’ll have to manually type in everything.

If you want it not to suggest based on prior search, then maybe would be based on Browsing History.

It might pop up with suggestions if you have Suggested Sites turned on, but don’t think it will be based on history. It can be annoying though on its guesses, which is why I turned that off.

Guess let me ask, how much of an auto-complete are you wanting as you type things? Are you wanting any type of suggestions at all?

Settings - Privacy and security - Brave 12_22_2022 01_48_26

Ideally, I want to see suggestions. I just want the option to select the suggestion myself, rather than having the top suggestion automatically applied (auto-completed). I think there should be a distinction between auto-complete and suggestions in the browser settings.

For now I’ll have to either disable “Browsing History” from suggestions (which I don’t really want to do), or I just need to be more careful/patient when typing a search and actually look at the address bar when I type. But of course that means In my previous example I have to type “thing”, then it auto-completes, then I have to hit backspace to undo the auto-complete before hitting enter. Which is an extra step.

1 Like

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.