How do I disable autocomplete?

bug
#1

I just installed Brave to try it out. I’ve been searching for like an hour to find where the apparently hidden settings are for the search bar. https://github.com/brave/browser-laptop/pull/9063 tells me to go to about:preferences#search, which produces an error: “The webpage at chrome://preferences/#search might be temporarily down or it may have moved permanently to a new web address.” These settings don’t appear to exist at chrome://settings/. Eventually I found https://www.reddit.com/r/brave_browser/comments/9rby08/implementing_searchaddress_bar_autocomplete/ which is the first indication I’ve seen that Brave has changed architectures and old information no longer applies. https://brave.com/brave-upgrades/ promises a seamless migration, I believe this post should serve as a counterexample. After creating an account here I was very frustrated to find that I was blocked from creating a new topic in the Help Center and Resources forum, which has in its description “Start here if you’re new to Brave or Community”. Apparently it’s not where I should start.

This whole experience has been confusing and frustrating. I would suggest putting a placeholder page at about:preferences that explains why the page has moved / no longer exists. I would suggest showing a note on installation explaining that Brave has changed architectures and old help articles no longer apply. I would suggest instead of having a “blocked” icon while hovering over new topic creation that there be some sort of link to a page explaining permissions for new users and how to ask a question. If it took me, a developer, this long to figure this out, there are many other users who never will.

#2

chrome://settings (or brave://settings) is where you’d look; its search field is in the top center in blue. You can get there from the “hamburger” menu to the far right of the address bar, too.

I don’t know if we can turn autocomplete completely off. If it helps, I’m pretty sure Brave only looks at your history to come up with suggestions because the “Use a prediction service to help complete searches and URLs typed in the address bar” setting is off by default. In Settings, scroll all the way down and click on “Advanced” and it’s not too far down the list.

1 Like
#3

Same here. Why the heck is it suggesting things I’ve never typed? When I type “n,” why do you assume I want to navigate to LinkedIn, when I’ve never typed that in this browser, and I have each tracking and autocomplete setting under the Advanced tab turned off?

This is a dealbreaker for me. I’m going back to Vivaldi.

closed #4

This topic was automatically closed after 30 days. New replies are no longer allowed.