Desktop sync error: "Couldn't contact Sync servers"



Description of the issue:
Sync error using Windows 10 desktop. Details below.

Steps to Reproduce (add as many as necessary): 1. 2. 3.

  1. Open the “Customize and control Brave” menu.
  2. Click “Sync”. This opens “Sync (beta) Setup” screen.
  3. Click the white “I have a Sync Code” button.
  4. Enter sync code.
  5. Click orange “Confirm Sync Code” button.

Actual Result (gifs and screenshots are welcome!):
After Step 3, an error message:
“Couldn’t contact Sync servers
You might be having network trouble, or there could be a problem with the Sync servers.”

Click “OK”, then go through steps 4 & 5. Result:
The orange button temporarily blanches, then becomes orange again. Nothing happens.

Expected result:
No error message. Complete steps 1-5, then connect to the sync server and synchronize bookmarks between devices.

Reproduces how often:
Every time, on my desktop Windows 10 PC. My laptop Windows 7 PC, desktop Linux PC, and Android cell phone have all synced as expected.

Brave Version(about:brave):
Version 0.59.35 Chromium: 72.0.3626.81 (Official Build) (64-bit)

Reproducible on current live release (yes/no):
Yes. That’s what I’m using.

Additional information
I uninstalled and reinstalled Brave. Same result.


having same issues on Windows 10


Thank you both for reporting and apologies for the late reply. I’m looking into this for you right now and will reply when I have more information.
Appreciate your patience.


Are both of you still seeing this error? Other reports I’ve seen on of this seem to be resolved with a browser or system restart.


Thank you for looking into it.

I no longer get the “Couldn’t contact Sync servers…” error, but still have the problem at step 5. Clicking the orange “Confirm Sync Code” button does nothing.

I installed Windows updates earlier today and had to restart. Nothing changed. Just let me know if any other information could be helpful.


Are you saying that after entering your Sync code, the button is unresponsive?


After entering my Sync code, the orange button still blanches when I click on it with the mouse, but that’s all. There is no indication Sync is trying to connect to my chain. The button is still responsive, though. After a few attempts, I click “Cancel” and can go back to the previous screen.


I see the same error.
Can you tell me

  • server dns name
  • server port
  • protocol (eg tcp,udp,etc)