Couldn't contact Sync servers You might be having network trouble, or there could be a problem with the Sync servers

sync

#1

Hi there, I’m having the same issue as in this locked post: Desktop sync error: "Couldn't contact Sync servers"

I installed brave on my laptop (windows 10), then synced it via QR code to my android phone - so far so good.

But now I wanted to sync to my desktop as well (windows 10), but using the seed words that I got generated on my phone doesnt work as I’m getting the error: "Couldn’t contact Sync servers

You might be having network trouble, or there could be a problem with the Sync servers."

Now I tried restarting both devices many times and I also tried leaving the chain on my phone and creating a new one, but unfortunately even the new seed words did not work and I’m getting the same error.

Any ideas how to fix this would be appreciated!

Thanks

EDIT1: actually found out that even if start from scratch on the aforementioned desktop and try to create new chain I get the same error after clicking “start a new chain syncing”. Would that narrow it down somehow?


#2

@mathos,
What version of Brave are you using and which direction are you syncing? Desktop --> Android,
Android --> Desktop, is it a smart phone or tablet?


#3

Yes hi - Im trying both directions - neither works. I have downloaded Version 0.60.48 Chromium: 72.0.3626.121 (Official Build) (64-bit) today so the version should be the latest official.

This being said the sync worked in the morning from my laptop - > android phone. When I wanted to add 3rd computer - desktop. I could not add it. I tried to start a new chain on both the android device and the desktop but getting this error. I tried things like running as admin - is there anything else I should try? Could it be somehow office firewall blocking?


#4

@mathos,
Office firewall may have something to do with this.
Is there a way you can try connecting outside the firewall or on a separate connection?


#5

Yes fortunately this desktop has a wifi adapter so I could connect to a 4g hotspot created on phone - disabled the ethernet adapter to be sure and the problem was exactly the same so it is not the firewall it must be something to do with my system. Any ideas how to narrow it down even further?


#6

I’m also checking under windows defender firewall - brave is allowed - is there any other process I need check if its allowed? Or do I need to allow both IN and OUT manually?


#7

@mathos,
I’m actually not sure - we’ve had users experience this issue before and, while diagnosing, Sync just “went through”.

is there any other process I need check if its allowed? Or do I need to allow both IN and OUT manually?

This one is tricky. I’m actually not sure about this, nor am I sure Windows Defender plays any part tbh. I appreciate your patience - I’ve reached out to the team for additional input. In the meantime, can you tell me (roughly) how many bookmarks you’re trying to Sync(BMs >100? >500?) and how are they organized (are they all in folders, some folders, folders with sub folders with sub folders – just a general description will do)?


#8

I’m now on my laptop which doesn’t have any issues syncing to my phone. I have couple of hundred passwords imported from chrome and I would say 100-500 bookmarks in various ways - some directly in the bookmark bar, then a lot of folders and some subfolders. Why the desktop has problems with it no idea. Thank you for looking into it - I’m happy to do more diagnostics if you give me instructions. I was thinking to search registry and delete all brave entries if there any left overs since I had few older versions installed on that system - do you think that could possibly help? Other than that I also tried reinstalling Brave, which didn’t help.


#9

Ok I have done some registry cleaning to no avail. One more thing that I noticed - my home laptop that is working fine with sync has win10 HOME installed and Im logged in with microsoft ID and I have “Hello” enabled, where as the office desktop has win10 PRO installed and only using logon password - could there be some differences in that? Other than that would updating all drivers including BIOS be necessary? I know on my laptop I have most of the things atest since it updates autmatically everything via Dell update, where as the desktop might be a bit older (I have only updated the nvidia card recently)


#10

As an update:

I did delete everything brave related, including registry entries, I did try to create new user under windows, updated windows to 1809, I have also unistalled most software that could interefering. The only thing I have not done yet is BIOS update. Is there anything else I should try?

UPDATE2: so I was up till like 3am trying to solve this (over teamviewer lol), now I’m back in my office and out of curiousity I tried on another desktop computer in the office. So basically same network, same version of Brave and it works like a charm! So the problem must be with the config of my main desktop. I really need to get it going on this particular desktop. I have another one that has the exact same specs that I’m gonna test it with (to see if it is HW related) if not then it must be SW related right? I would like to avoid reinstalling windows, unless it is the last resort. So I’m gonna ask again - is there any other troubleshooting that could narrow this down to HW/SW on this machine?

UPDATE3: tried safe mode with networking - same problem, also tried to kill almost all processes/tasks running - one by one and while I was clicking on sync after I closed a bunch - close almost everything non-essential, didnt help.

UPDATE4: updated to latest BIOS, gonna check all the drivers now.

UPDATE5: all drivers are now up-to-date, problem is the same

UPDATE6: important one - I successfully synced on an identical desktop machine I have in the office (HW-wise it has the exact same components) so I can narrow it down to SW issue I guess?


#11

@mathos,
Truly great detective work! I really appreciate the effort put in to diagnosing. After reaching out to Sync team, there’s additional data that may be useful to have. For anyone running into this error, can you please perform and provide the following:

  1. Open brave://inspect/#extensions in tab
  2. Click inspect link under Brave Sync
  3. Click [Console] tab
  4. Find sync-setup-error message with details. Search for error text found here - namely anything that looks like error=Failed to fetch - this message may be surrounded or enclosed by other characters so it does require a bit of eyeballing.

Any help/data would be greatly appreciated. You can leave that data here and I will make sure it gets to the right people.


#12

Hi great thanks! It is amazing the team got back quickly - I can follow your steps until point 3 - where I click on the console tab but the console is empty, even if Im trying to click on confirm sync code in the left window - am I missing something?


#13

@mathos,
While that is inspecting, the menu you’re looking for is specific. You must type the brave://inspect/#extensions command into the address bar directly, as I’ve done below:


Let me know if this is still unclear.


#14

Ahhh I tell you what - when I copy and paste this link in the problematic desktop it doesnt even have the brave sync under extensions - I have to click on the sync now button in order for it to appear - I tried it on the other computers where it works properly and the brave sync with inspect option shows normally… Anyway these are the errors:

image

Hopefully that will shed some light?


#15

That definitely does shed some light - this is good info. We released an update to 0.61.51 just a bit ago, can you check and see if you’re still getting the same issue?


#16

Yes - just did the update and restarted PC - the problem remains unfortunately…
image

and you know what - I find it really difficult to click on the inspect button under the brave sync extension - it keeps disappearing and most of the time the click doesn’t do anything - have to really do some hoops and loops to make the console pop-up - like going to sync tab several times and I think it actually has to start new sync chain in order for the inspect button become clickable.


#17

Some more details on this issue - sync works correctly on my Windows 8.1 machine, but not my new Windows 10 system. Both having the latest Brave version installed Version 0.61.51 Chromium: 73.0.3683.75 (Official Build) (64-bit). The error returned by sync.brave.com/(id)/credentials is: Signed body request of the client timestamp is required


#18

@Mattches hello good sir - just wanted to see if there has been any updates on this? As @blade_sk found out a bit more about this error? I’m sure it must be something small and ridiculous causing this… Or is the only advice the team recommends to reinstall windows? I’m willing to do that but I think it is best for everyone to find out what is causing this error.


#19

@mathos,
We’ve been pretty slammed with Rewards on Android going live – sorry again for the late response. @blade_sk, thanks for the additional info!

No updates yet unfortunately but I’ll see if I can get one – I would also like to see this solved asap. Please bump this thread if I haven’t responded in a couple hours or so.


#20

@mathos @blade_sk
I am 99% percent sure the issue is caused by wrong system time and/or wrong time zone.
Sync credential server requires clients to have the correct system time to resolve sync changes correctly.
Unfortunately, this error is hidden with a common description of Couldn't contact Sync servers .
There are an issues created for this case:



to inform about the situation properly.

Thanks,
Alexey