Default setting for blocking cross-site trackers not working

Description of the issue:
My default setting for blocking cross-site trackers is enabled but every time I visit a new site when I click on the shield it’s disabled. If I move the slider and enable it for a specific site the configuration option is retained, even after I close and reopen the browser, but the default of on is not used when I visit any new sites.

Actual Result (gifs and screenshots are welcome!):
The top image is my default config and the second is a site I visited for the first time.

Expected result:
That the default setting is applied to every site I visit automatically.

Reproduces how often:
100% of the time.

Operating System and Brave Version(See the About Brave page in the main menu):
Brave x64 1.1.20, Chromium 79.0.3945.74
Windows 10 Enterprise, build 17763

The first thing that comes to mind is that you have some data configured to “reset” when the browser is closed/quit – however, based on your images, it seems that the default Shields settings you have (which also happen to be the defaults out of the box) would be what they reverted to, were they being reset.

We should check and see anyway. Can you see if you have any data set to be cleared “on exit” – namely Site settings or Cookies/Site data by going to Settings --> History --> Clear browsing data --> [On exit] and see if any options are checked.


All the options for On Exit are unchecked. I even tried disabling uBlock Origin, just in case the two protection mechanisms were fighting it out somehow, but that didn’t change anything unfortunately.

That is very strange. Would you mind testing the behavior while using a new/fresh Brave profile? I’m wondering if there’s some sort of site data/settings shenanigans going on in the background causing this behavior. To test, simply:

  1. Open the Profile menu
  2. Select Manage profiles --> Add person to create a new profile free of browsing data.
  3. When the new profile window opens, ensure your Shields settings are properly configured at their default settings:
  4. Then, browse normally for a bit, visiting sites you regularly do and note the settings in the Shields panel for the sites.

Let me know whether or not you get the same behavior.


I couldn’t find a Profile menu but I did create a new profile using the highlighted item:

When using that profile I had none of my extensions or configurations - the expected result - and the default Shields settings worked fine:

I then went back to my normal profile and disabled every extension but that didn’t resolve the problem so I don’t think it’s an extension.

Very strange – can you try clearing your cache/site data in the browser? Maybe some bad cache data is causing the settings to confuse themselves.


I clear my cache at least once a week. Using Advanced and a time range of “all time” I clear the following areas:

I haven’t removed cookies or site data because I’ve been using the browser at home and work for almost 3 months now and I have tons of cookies and site-specific data. If I knew that was the fix I’d clear it, but if it’s not a certainty (or close to it at least) I’m reluctant to redo all that.

This morning I updated to the latest version (1.1.22) hoping there was a fix in there but the issue is the same unfortunately.


That’s totally understandable and I agree completely. Unfortunately, I believe that would be the data to clear if this were the cause of it. I’m reaching out to a couple devs to see if they have any alternative suggestions – appreciate your patience while working through this issue.

To clarify, is it only the cross-site trackers default setting that isn’t respected, or are there other (or all) protections that behave the same way?

Correct, only the cross-site trackers setting is not working.

I just took a backup copy of my entire folder and saved it, then I systematically went through all the unchecked options and it turns out Site Settings is the culprit. I always have Download History, Cached Images and Hosted App Data selected so those I left as is. When I got to Site Settings that cleared up the problem.

1 Like

I just noticed something else, all my extension icons are missing…

Not sure when that happened but 6 of my extensions should have an icon so it seems there is more wrong than just the Shields issue.

@theJman This might help in terms of “missing” extensions…

1 Like

Good catch – we have an open issue for this on our Github:

Can you confirm whether or not the solution provided by @megaspaz works for you?

The suggestion from @megaspaz did not work unfortunately. I set #extensions-toolbar-menu from default to disabled and then restarted, still no icons. I set it to enabled and relaunched but the same result. Finally I set it back to default and relaunched, no change though.

Just a quick update… nothing I tried brought back the extension icons so I removed each and then reinstalled them. The icons remain even after several reboots so it looks like that resolved the issue. There’s still likely a problem with Brave to cause it in the first place, but at least the icons are back.

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.