Brave Shields ignoring "global shield defaults"

Description of the issue:
Brave Shields are blocking Cross-site trackers even though I changed the default setting to NOT Block cross-site trackers.

How can this issue be reproduced?

  1. Click the Brave Shields icon
  2. Click “Change global shield defaults”
  3. Unselect “Block cross-site trackers”
  4. Visit a website such as
  5. Brave blocks cross-site trackers

Expected result:
Brave shouldn’t block cross-site trackers

Brave Version( check About Brave):
Version 1.5.115 Chromium: 80.0.3987.149 (Official Build) (64-bit)

Additional Information:
Brave Shields is a fine concept. But I need my web browser to “just work”. I want the option to turn Brave Shields off entirely. I’ve already disabled all of its settings, but it still messes with cross-site trackers.

1 Like

I’ve have one of my profiles with Site-trackers disabled globally on my main profile, I’ll leave the other options enabled (fingerprinting, cookies and https). this works for me.

Only time it wouldn’t, if you manually adjusted the site-tracker in Shields for that site. If you visit a a completely new site, it should follow the global settings you have.

I created a fresh VM and tried to replicate the issue on it, but so far I cannot. I guess I need to find the difference between my main box and my VM.
I haven’t manually specified any per-site shield settings. Going to new websites I’ve never visited before still blocks cross-site trackers despite the global setting for blocking cross-site trackers being turned off. Definitely looks like a bug, but it seems I don’t know the steps to reproduce it.

Turns out it was also forcing upgrades to HTTPS in addition to blocking cross-site trackers despite both options being turned off.
I got it resolved. I’m still not sure what caused it in the first place.
I don’t know the exact sequence that resolved the issue, but I started toggling the global switches on and off, and I toggled between simple and advanced view in both the settings page and in the Brave Shields drop down on the URL bar.

To confirm, Shields settings are now working/being respected?

1 Like

Yes sir, the settings are being respected now.
Somehow my global Shield settings for “Block cross-site trackers” and “Upgrade connections to HTTPS” were not being respected.
However, the issue was resolved by toggling them repeatedly in addition to switching between “Simple view” and “Advanced view”.


Thanks for confirming! :slight_smile:

1 Like