Dark Mode always seems to set the opposite?

Description of the issue:
Although I have Brave (1.46.144)'s theme set to ‘Same as MacOS’, and MacOS is on a schedule and currently on Dark Mode, if I go to any website whatsoever – even Brave Search – and set that website to ‘automatic’, it immediately presents something like Brave Search in Light Mode. I have to force manual dark mode on every website when using Brave!

Steps to Reproduce (add as many as necessary): 1. 2. 3.
Fairly obvious
Actual Result (gifs and screenshots are welcome!):
Even though Brave is Same As MacOS and therefore dark mode, websites for some reason default to light mode
Expected result:
websites should default to dark mode
Reproduces how often:
100% of the time
Operating System and Brave Version(See the About Brave page in the main menu):
Mac OS Ventura 13.0.1
Brave 1.14.144
Additional Information:

Yeah, if this works like my iPhone, then I know what you’re getting at. The issue here is site settings vs Brave settings. For example, if I go to a website that lets me toggle Night mode and I have it set to Dark Mode by default, but then one day I visit with Brave in Dark Mode, then they both trigger and cancel each other out.

Brave Dark + Site Light = Dark
Brave Light + Site Dark = Dark
Brave Dark + Site Dark = Light
Brave Light + Site Light = Light

Your situation may be a bit different, but I think it’s same in fashion. So if your OS is putting into Dark and Brave is then toggling to Dark, it might be overlapping and creating Light.

But if not, then it may just be specific site settings. Like Brave Search in Dark and Brave being in Dark will result in Light.

Not quite. I’ve set my Mac OS to Dark just to test this. It’s not automatic right now. I’ve set Brave’s theme to Automatic, which means it’s dark. Brave Search is set to Automatic.

Aaaaaaand the search results are in Light mode.

What on earth is wrong with Brave?

I’ve solved it. What I had to do was lower the ‘Block fingerprinting’ setting under Brave Shields to standard. The ‘Strict’ setting for some reason was disabling any attempt by websites to switch automatically to light/dark correctly.

1 Like

Ok, awesome. So working that way for it. Otherwise knew how I mentioned before is how it’s working on my iPhone anyway. I was about to say if nothing else you may have had to keep one of those set to Light mode for default that way the other Dark would toggle. But, no more needing to mess with it! lol

1 Like

Additional information that may allow you to set fingerprinting to strict and still use dark mode. Would be interested to know if you disable this flag if it works for you. Please post an update if you try this. Take care. :slightly_smiling_face:

Action: Disable brave://flags/#brave-dark-mode-block

Brave GitHub Issue Report:
Enabling Brave Shields breaks “Sync with system” theme setting on multiple websites. #21220

Reference Comment:

nastavoi commented on Feb 27
Try to set this flag to disabled. Github, google etc. should then detect system theme just fine when strict fingerprinting is enabled.

It was added sometime ago in brave/brave-core#9735

1 Like

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.