Brave Settings Page Won't Utilize Dark Mode Preference (macOS Intel)

Version 1.27.69 Chromium: 91.0.4472.106 (Official Build) beta (x86_64)

In brave://settings/appearance, When I try to set the Brave colors option to “Dark”, the settings theme does change temporarily. However, when I then navigate through the settings by clicking one of the options on the left side bar (Or even close the tab and open a new settings page), the theme seems to return to light mode. The weird part is that the Brave colors option still says that “Dark” is selected, and the only way to return to dark mode is to set the option to Light, and then select Dark again (Although it just returns to light mode the next time I open settings). I should note that only the Brave settings page utilizes the light mode against my actual settings, the rest of the Brave UI does continue to use dark mode. Is this a known issue? I’ve had this issue for a while on Windows Nightly as well, but I had quite a few flags enabled, as well as extensions, but now that I’m seeing it on my MacOS blank Brave Beta too, I don’t think it’s an issue on my end.

In the image below, you can see the option is set to dark mode, yet the theme is light.

I’ve tried disabling extensions, and I don’t have any flags enabled in brave://flags.


for me also bro literally my eyeballs are popping out when seeing settings.this bug is here in brave beta windows also


Version 1.27.69 Chromium: 91.0.4472.106 (Official Build) beta (64-bit)

This is happening on Windows 10 as well. Was pretty annoying to see that brave switched to light only to find out the selection is broken, now extensions that rely on the browser settings all switched to light mode.


I also notice a few site that having it’s own dark mode function having the same behavior as you mention. for example Subsplease they have dark mode option. Anytime I turned the dark mode on. normally in safari or chrome even if you close the whole browser and open it again it will stay on dark mode in subsplease, but in brave it’s just goes to light mode.


Do you have fingerprinting protection set to “strict”? If yes then try to change it back to standard and check if dark theme is working again. Something similar was reported on Github.


thanks bro it works totally perfect

That solution did end up working for me, thank you!

I would like to use strict fingerprint blocking in my day-to-day use though, so hopefully they can find a fix for this issue.

Thanks for reporting this. Night mode fingerprinting protections should not apply on brave://settings or new tab pages. Fix merged in here:

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.