Dark mode not working on sites even though system dark mode is used

Description of the issue: Dark mode not working on every site that supports dark mode if it’s in sync with the laptop/mobile’s system default. But it’s working on a stable version.

Steps to Reproduce (add as many as necessary):

  1. Brave browser’s nightly or beta can be used.
  2. open https://search.brave.com/
  3. Change theme settings to system
  4. Make sure to make the computer’s theme dark mode.

Actual Result (gifs and screenshots are welcome!):

Expected result:
The dark mode should be enabled for every site that supports dark mode which is in sync with the system’s theme.

Reproduces how often: every time

Operating System and Brave Version(See the About Brave page in the main menu):
Operating System: macOS Ventura Version 13.2.1 (22D68)
Brave Version:
Version 1.51.19 Chromium: 111.0.5563.64 (Official Build) nightly (arm64)
Version 1.50.85 Chromium: 111.0.5563.64 (Official Build) beta (arm64)

Got it. Fixed the issue.
I enabled Aggressively block fingerprinting, that was the cause of it. Once I downgraded the setting, now it’s working fine.
But how does dark mode related to fingerprinting setting?

Websites detecting which OS or Browser theme setting you have set to automatically apply something like dark theme, could be surely used for fingerprinting purposes.

Strict being the highest protection, should have the highest protections regardless if they are useful or not, like how WebGL doesn’t work in Strict mode

That’s why Brave made that change almost 2 years ago:

And that’s also why Brave created brave://flags/#brave-dark-mode-block if you want to use Strict and still get your dark mode detected, they know it is useful.

You can see the other Fingerprinting protections Brave has added:

1 Like

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.