Can't log into Google services (gmail, gcal, maps)

Can no longer log into any google services through Brave. I can enter my password and it get an error message stating " The server cannot process the request because it is malformed. It should not be retried. That’s all we know." This issue has persisted for over a week and is super inconvenient. I looked on forums and tried restarting my macbook, clearing cache/cookies, and uninstalling extensions but nothing has worked.

I am using Brave version:
Version 1.48.171 Chromium: 110.0.5481.177 (Official Build) (x86_64)

I am using Macbook Air 13-inch, 2017 OS Catalina 10.15.7


Have you tried in a private window yet?
If that works it’s probably some extension or bad cookies interfering.
Remove extensions and cookies to see if that helps.

No it does not work in a private window either. It does work fine in a different browser like Firefox. Does not work if I have removed extensions and cleared cookies.

Could you try in a new profile ?

I can access through a new profile. Is there any way to merge bookmarks/passwords etc between profiles if I’m going to have to start using a new profile? Or given this new information do you have an idea how I can access gmail through my old profile?

1 Like

Could you try clearing browsing data in the old profile ?

Maybe use Sync to sync old and new profile ?

Hi there @jmb14228, on your previous profile have you tried disabling your shields to see if they were interfering with your log in?

I had the same problem with the error code 400.
Even with a virgin installation of Brave (new user).

Allowing traffic to resolved the issue for me.

1 Like

@aCitizen did you add it on your shield settings or did you perform other steps to add it?

@Kevin_cc The issues wasn’t caused by Brave browser nor was it fixed in Brave browser.

I use Little Stich on macOS to block suspicious outgoing traffic and I had chosen at a time to block for the domain. The domain is essential for using Google services.

1 Like

@aCitizen thanks for your response!

@jmb14228 do you have any third-party program that may have been blocking access to Google services through Brave? If you have please disable it to see if you are able to properly login.