Google 400. That's an error. The server cannot process the request because it is malformed. It should not be retried. That’s all we know

Description of the issue:
Unable to complete google account log-in authentication. Arrive at error page (screenshot below) after completing log-in.

How can this issue be reproduced?

  1. Open Brave
  2. Open New Window
  3. enter https://mail.google.com/ (or gmail.com)
  4. error page produced

Expected result:
Arrival at google account home page upon log-in (gmail, etc).

Other:
I have tried the following which have each failed:

  • System Reboot
  • Brave Restart
  • Brave Clear browsing data
  • Brave Clear cookies and other site data
  • Private tab attempt
  • Turned off all extensions
  • Attempted log-in to second/different google mail account (via university authentication) and it also fails and lands on the same error page.

Successful attempts using:
*Open Guest Window in Brave
*Using Different Brave Profile
*Using Firebox

url of error page as copied from brave url bar:
https://mail.google.com/accounts/SetOSID?authuser=0&continue=https%3A%2F%2Fmail.google.com%2Fmail%2Fu%2F0%2F%3Fpli%3D1&osidt=ALWU2ctZMmOJieUyMQFFvPbucQRr-sFxi3pb-wg6EDHr3VfNjP7I5PcO_m5HZHA2iPCYuyXgzOgbB4Ht-b-A7IS-gaUwhq6twwX1XnFNPAjgn6FYr97cQOCiY-72cmcKPFVaMX1mPX2gdXKscuSggoGZLLnNjXwaIDBzlcAlWh9V-YC-hwR78UDvN4GgxYBTR_REgw1szVPKgbdS0_7hX2gwB9pI59L1ng&ifkv=AU9NCczUyzSERKnINNHdndiOXd-3ORIHl3HXd-JBRdp0ZzqWe_9vmsBPshlZodlNEnveCWkQLQ97sA

Brave Version( check About Brave):

Version 1.37.113 Chromium: 100.0.4896.88 (Official Build) (x86_64)

Additional Information:

1 Like

@dingdingpowpow,
I would wager a guess that this also works in a new browser profile as well, is that correct?

Yes. I was able to access google/gmail successfully with a new brave profile.

Not sure if useful, but on my primary brave profile I also attempted a log-in to an institutional email that is hosted by google/gmail with its own authentication, and that too was unsuccessful.

Can you try (on your main profile) with Shields down (lion icon in the address bar)?

In the meantime, until they get it fixed - this works:

  1. Go to https://crxextractor.com/
  2. paste the URL from the Chrome Store to the extension
    you want and the the .crx file
  3. Open your extensions tab in Brave
  4. Drag and Drop from the folder you downloaded the
    .crx file to the extensions tab
  5. Dance and Happy Dance of Joy and Relief
    :dancer:t6::dancer:t5::dancer:t4::dancer:t3::dancer:t3::dancer:t2::dancer::dancer:t2::dancer:t3::dancer:t3::dancer:t4::dancer:t5::dancer:t6:

Hope it helps!

Unsuccessful. Shields down results in same error page on google’s end.

thanks for the troubleshooting, btw, mattches.

1 Like

I started having this issue as well. Logging into Gmail from incognito was unsuccessful as well, however, new browser (Chrome) seems to work. Disabling the Lion allows me to open Gmail.

From the inspect element page, I saw this error, which I could find very little from Google searches.

Uncaught ReferenceError: deAmpEnabled is not defined

@dingdingpowpow,
You may need to turn Shields down on the 400 error page itself in order to get into gmail.

Experienced same issue as stated above. SOLVED by enabling cookies from gmail, cross-site cookies can still be blocked, Shields can stay UP.

2 Likes

I have allowed all cookies in shield, rest of the shields are default and gmail is working again.

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.