Can't download or save on linux

Description of the issue:

For the past few weeks I can not download or save a page. Prior downloads appear in the download page, but new downloads do not. Pages can not be saved. I have also noticed strange behavior when selecting a file for upload, where selecting a file does not actually choose it in the page. I suspect this might have to do with the latest updates to gnome 42.

How can this issue be reproduced?

  1. Click on a link that should start a download. Nothing happens.
  2. Rightclick on a page and press “save as”. Nothing happens
  3. Open a PDF and press the download in the right top corner next to print. Nothing happens.

Expected result:
In any of those cases, it should start downloading or prompt for a place to save.

Brave Version( check About Brave):

Version 1.37.113 Chromium: 100.0.4896.88 (Official Build) (64-bit)

Additional Information:
gnome 42 on debian testing (bookworm)

Thank you for reaching out.
Not clear on what might have caused this on our end. I’m going to check with the team. In the meantime, would you mind creating a temp. new profile and testing to confirm that the issue occurs when using the new profile as well?

@macdabby,
Additionally, can you tell me if you installed Brave via snap?

I tried with a new profile and the same thing happens. I installed with apt / aptitude which shows the version 1.37.113. I also have been able to save and download in the past and was using this same install, but i’m on testing/bookwork and just started getting the gnome 42 updates so im thinking it might have something to do with that.

1 Like

I think that it may. Thanks for the update —hope to have more info for your soon.

any update or anything I can do to help this along? It’s seriously crippled my workflow. Firefox is working and I’m hesitating to move everything there but once I do it’s going to be hard to migrate back.

@macdabby,
Apologies for the long wait time here. To narrow down whether or not it is GNOME related, can you try installing KDE and logging in using that desktop to see if this makes any difference?

I switched to KDE and it worked. I switched back to gnome just to see if it was a library that was installed with KDE but gnome still does not work.