Unable to download anything on linux

I’m unable to download anything via brave. I am getting no pop-up, nothing.

It was all working ok for many months, but recently something has changed.

I’ve opened brave via terminal to see if I’m getting any errors, only thing i got meaningful is:
[1453841:1453841:1206/151032.489353:ERROR:CONSOLE(1)] “[Shields]: Can’t request shields panel data for tabId: 119. Error: No tab url specified”, source: chrome-extension://mnojpmjdmbbfmejpflffifhffcmidifd/out/brave_extension_background.bundle.js (1)
Linux, Mate Desktop
5.14.18-200.fc34.x86_64
Version 1.32.113 Chromium: 96.0.4664.45 (Official Build) (64-bit)

@tmdag,
Do you have any extensions installed in the browser at this time?
Additionally, can you tell me if you’re trying to download via clicking links only? For example, if you go to your preferred search engine, search an image then right-click Save as... Does this allow you to download the image?

I’ve tried on private window - same thing.

and nope @Mattches , save image as is also not bringing anything at all.
If I want to quit browser - it asks me if i want to cancel my downloads tho (while there are none)

@tmdag,
Would you mind testing the behavior in a new profile as well?

created new profile - same thing.

Tried downloading image (nothing) tried downloading anything from web, lets say https://zoom.us/download. - nothing (on that new profile)

Hello @tmdag

what is your linux distro? and version

could you try to restart your whole computer or at least go to brave://settings/system and disable Continue running background apps when Brave is closed then restart brave

1 Like

Fedora 34.
I was restarting before, it started happening few days ago. But I did restart once again for this test, as well I have disabled option you have mentioned @justsomeone1 .

Started working now, thanks! Will keep posted if it comes back (unless you guys want to investigate further of have some ideas what might be causing it?)

The only recent plugin i’ve added was https://github.com/pmarks-net/ipvfoo . I can remove it - maybe that’s a trouble maker (?)

you welcome i guess it was freez in the background and this option allow the browser to run in the background so it be faster to load when you open it again but if issue happen then it will stay running

not sure why not the other restart help

edit : for the extension you mentioned if the issue show up again try to disable it and notice if it really cause an issue

glad to know it work fine now :slight_smile:

1 Like

ok, problem came back again after 2 days. This time plugin in question was turned off.

sorry for late replay @tmdag

when that happen does closing your browser help or not?

could you disable all extension and clear cache and try again ?

could you create new profile and use the new one for while without any extension and see if the same issue show up?