Can't Connect Wallet to Adobe Account

Issue:
Adobe now lets us connect Metamask and Phantom wallets to our Adobe account. I assume the Brave browser wallet would connect via the Metamark button. However, when I tried, I got the error message, “Something went wrong. Please try again later.”

URL:

Shield:
I tried with the shield on and off. Same issue.

Brave Version:
Version 1.42.97 Chromium: 104.0.5112.102 (Official Build) (arm64)

Hello,

Thank you for bring this to our attention. We are looking into the matter.

Thanks!

There is now an open issue for this concern. You can track it here: https://github.com/brave/brave-browser/issues/25039

Thanks!