Can't add my Android phone to a sync chain

Description of the issue:
My previous phone’s screen cracked so I got a replacement in the exact same model (TCL 20s, model T7730), but transferring all of my sync settings from the old phone to the new phone simply refuses to work. I scan the QR code or type in the chain code, but while my new phone gets added to the sync chain, immediately after I do I get a push notification on my new phone that says “Sync isn’t working. To start sync, enter your passphrase”, and when I tap on the push notification it just disappears and nothing happens. I try to delete my new phone from the sync chain to try again, and most of the time I’m stuck on a screen that says “Leaving the sync chain” and nothing happens until I have to keep repeating the same step over and over until after approximately the fifth time when the new phone is successfully removed from the sync chain. When I go to Settings > Sync on the new phone, there’s no Data Preferences option whatsoever, and there’s no way for me to access the “Sync everything” menu before I begin the process of synching all of my data to the new phone when I select the Sync option. Is the fact that my two phones are the exact same model what’s causing the problem?

Steps to Reproduce (add as many as necessary): 1. 2. 3.

  1. Open “Settings” on new phone, the target of all the data I want to be transferred from the old phone
  2. Tap “Sync”, which immediately pulls up the following screen:
  3. Scan QR code or type chain code to add new/target phone to the sync chain
  4. New/target phone is added to the sync chain, but a push notification saying Sync isn’t working appears simultaneously
  5. Option to sync everything is nonexistence on new/target phone. The following screenshot has been taken from the old phone, the source of all the data I want to sync/transfer for the target phone, but the options shown on-screen are identical to the new/target phone after being added to the sync chain, where only by tapping Sync options does the Sync Everything menu appear. This menu never appears before the target phone has been added to the sync chain (despite Sync Everything being enable on all other devices on my sync chain) and as a result the data I’m trying to transfer to the target phone in the first place never appears at all

Reproduces how often:
Every time (no successful Sync to the target phone has occurred)

Brave Version(See the About Brave page in the main menu):
Brave 1.66.118, Chromium 125.0.6422.147 (both phones)

Type of devices currently running on the Sync chain in question:
iPad, Desktop, T7730 (source phone)

Additional Information:
Operating system for both phones is Android 11; Build/RKQ1.210107.001

Hello @ShrekDotCom ,

Thanks for the report, I was able to reproduce the issue, with except that sync worked good on both devices.

Logged here, I’ll work on it as a next task.


Thank you, hopefully this problem will be fixed soon!

Update: I tried again to see if it would work now, but my results are identical to the problems I was having before, with the exception that Brave doesn’t freeze when I remove my phone from the sync chain anymore. However, I accidentally removed the source phone from the sync chain in addition to the target phone so I’m trying to add the source phone back to the sync chain in order to properly transfer all of my data, but now I’m having the same exact problems as I was with the target phone (if I scan the QR code from either my iPad or desktop PC, I still get the same exact error message saying that sync isn’t working, to enter my passphrase to enter sync, and nothing happening once I tap on the notification) Is this a problem with Android specifically?

Current update: Since a new version of Brave has been released, I made sure both the source and target phone were on the newest version before I tried to add my new phone to the sync chain again. This time I didn’t get the “Sync isn’t working” push notification after scanning the QR code on the source phone but the data still won’t transfer over, and when I try to exit the target phone from the sync chain to star over I just remain stuck on the “leaving the sync chain” screen