Can't access websites (your connection to this site is not secure)

Description of the issue:

i can’t access a number of sites. i’m not sure why. i’ve tried with shields down, as well as without my VPN. still shows ‘untitled’ as the tab title.

there is a warning sign, before the https: for the website… when click on this it says
‘your connection to this site is not secure’.

this happens on two sites im aware of:
https://www.nimiq.com/ (for this site it just says 'your connection for this site cannot be reached)

the second is a link to a QnA call… where the end of the linked address is
‘.lt.acemlna.com’

wonder if there is a setting i can change to allow me to access these links/sites?

otherwise i may consider downloading another browser for specific sites i can’t access, which would be a pain.

Steps to Reproduce (add as many as necessary): 1. 2. 3.

Actual Result (gifs and screenshots are welcome!):
image

Expected result:

Reproduces how often:
every time access links/page

Operating System and Brave Version(See the About Brave page in the main menu):
windows 10.
brave version. 1.38.11

1 Like

@Loquat ,

Suggestions for improving your chances

Assuming that you normally wish to have / leave Brave Browser > Shields: UP

Including the Global Shields Settings:

Global_Shields_Settings

In a Brave Browser > New Window, go to: brave://settings/cookies

Disable: Clear cookies and site data when you close all windows

Next, go to: brave://settings/clearBrowserData . . . and select the Clear browsing data > Basic tab.

Being as thorough as you believe necessary, select what you would clear and click on the Clear data button. NOTE: the Clear cookies and other site data selection (when Enabled) will sign you out of most websites.

Next, return to: brave://settings/clearBrowserData

For the Clear browsing data > On Exit tab:

Disable: Passwords and other sign-in data
Disable: Site and Shields Settings

Click on the Save button.

In a Brave Browser > New Window, go to brave://settings/cookies

Scroll down that settings page, to Sites that can always use cookies

Click the Add button

Enter https://[*.]nimiq.com:443 as the site . . . but do not Enable

  • Current Private session only
  • Including third-party cookies on this site

Click the Add button

Repeat those steps for the following entries:

www.nimiq.com:443

Next, go to brave://settings/content/javascript

Scroll down that javascript settings page to Allowed to use javascript

Click the Add button

Enter https://[*.]nimiq.com:443 as the site . . . but do not Enable

  • Current Private session only

Click the Add button

Repeat those steps for the following entries:

www.nimiq.com:443

In a Brave Browser > New Private Window, go to https://www.nimiq.com/

IF not already allowed in the site-specific Shields (Lion icon) panel, then Allow the source of blocked scripts: www.nimiq.com - for example, click on the Allow button:

Screen Shot 2022-05-06 at 5.11.52 AM

If you observe the Brave Browser > Developer Tools > Network activity, you learn that somewhat-dynamic ordering of downloads from a website to Brave Browser, occurs. By “somewhat dynamic” I mean, that some items must download before other items.

If there is a glitch re the order of some downloads succeeding, then a state of security re the connection between the website and Brave Browser, may not yet occur . . . and thus, the padlock icon will not yet appear.

Instead, there is usually a circle with an orange/red field and an exclamation point within that, indicating that “this site is not secure”.

A reload of the web page, or closing the Brave Browser window, and using a Brave Browser > New Window -or- New Private Window - trying to connect to the URL address, again . . . may succeed.

Sometimes, determination is required, despite the frustration and delays. (I tend to be very determined, re this issue.)

Re your attempts to connect to https://www.nimiq.com/ , there is a a common www.nimiq.com source for the many javascripts that are downloaded from the website to Brave Browser:

www.nimiq.com/js/custom.js
www.nimiq.com/_nuxt/app-69a546212f1f0fc673a3.js
www.nimiq.com/_nuxt/chunk-854c2f47a89c55a98d33.js
www.nimiq.com/_nuxt/chunk-4b48af934bc591b8d40e.js
www.nimiq.com/_nuxt/chunk-13de5600a85e0c89984a.js
www.nimiq.com/_nuxt/chunk-09059cdb492799802c2e.js
www.nimiq.com/_nuxt/chunk-b7e0b2cb6656caf55dd8.js
www.nimiq.com/_nuxt/chunk-a12523891f5b66f124b9.js
www.nimiq.com/_nuxt/chunk-af87d7cc6f9449913d70.js
www.nimiq.com/_nuxt/chunk-6dae216486a0ad16872b.js
www.nimiq.com/_nuxt/chunk-13ff09ccd96b9b2a9798.js
www.nimiq.com/_nuxt/chunk-c47133e7049065e07ab2.js
www.nimiq.com/_nuxt/chunk-02af646ef78519e3ef6b.js
www.nimiq.com/_nuxt/chunk-462929a9c0d97d935406.js
www.nimiq.com/_nuxt/chunk-fa6ca21ff413c68a172c.js
www.nimiq.com/_nuxt/chunk-df23452890580db0cda7.js
www.nimiq.com/_nuxt/static/prod/state.js
www.nimiq.com/_nuxt/static/prod/payload.js
www.nimiq.com/_nuxt/static/prod/manifest.js
www.nimiq.com/

A delay, or missing, download of a necessary javascript (or some other item that the website tried to send to Brave Browser), can result in a delay of, or halt, a successful appearance of the padlock icon.

thanks so much for this amazingly thorough guidance.

i so appreciate it.

i went through all the steps, and changed all the setting you mentioned… but still doesn’t allow me to load the nimiq.com page…

i did learn a lot about brave settings :slight_smile: and will be using private window from now on too… thanks for tip.

will ask about if on the nimiq telegram group. see if anyone else having similar problems.

thanks again

colm

@Loquat ,

Thanks for taking the time. It is a crash course.

I would return to: brave://settings/clearBrowserData . . . and select the Clear browsing data > Basic tab. Enable all 3 selections and click the Clear data button.

Try “Troubleshoot Compatibility” - might work:

More . . .

In a Brave Browser > New Window, go to: brave://net-internals/#dns

and click on Clear host cache

Next, go to: brave://net-internals/#sockets

and click on both (in succession):

  • Close idle sockets
  • Flush socket pools

Exit/Quit everything and restart your computer.

In a Brave Browser > New Window - go to: brave://settings/security

Disable: Use secure DNS

And maybe . . . in a Brave Browser > New Window, go to: brave://settings/?search=Continue+where+you+left+off

And adjust the settings to about:blank as shown;

If you have Brave Browser to be the default Browser, choose a different Internet browser for that.

IOW, take steps to get Brave Browser free and clear from as many burdens as you can.

thanks again for all the troubleshooting…
i tried it all… and again, no luck… yet…

last resort may be to try it using another browser… will download tor later, and enable javascript, which i see if needed for nimiq wallet…

but i did get into the other link, with sovereigns way website… so that’s one success out of two :slight_smile:

appreciate the caring support.

@Loquat ,

Uh oh . . . “nimiq wallet”

That is a Brave Rewards issue.

Possibly, the following method parallels what you might do:

ok. thanks for heads up…
yes, many hoops to jump through…

i messed around with the brave wallet, trying to remove it, and don’t need it… but no luck…
didn’t try the uphold.com advice, as seemed a little unrelated…

but, finally i did try, again, to take off both of my vpn’s (on phone for hot spotting, and laptop).,. and wallet worked… which is great… won’t be using it much at all… but good to know can access if want.

another question if i can…

i see from the forum, that many people would like to have private browsing as a default… whether we can have private browsing always activated, when we open brave… when i open a link from somewhere else… i see that it doesn’t allow this… which i feel is pretty important… would be great to not be browsing at all in the ‘public’…
any tips with this.

thanks so much for all the help… glad i finally got in the sites i wanted…
was probably a combination of all the things i tried from ur suggestions :slight_smile: