"Establishing secure connection..."

windows
#1

Description of the issue:
More often than not, loading any page I get a message at the bottom of the window saying “Establishing secure connection…”. This is usually followed by a failed attempt to connect to any website. This happens with every site I use, even search engines (google, duckduckgo). Sometimes the browser works flawlessly for a while, other times this error is all i get.

Steps to Reproduce (add as many as necessary):

  1. Launch browser
  2. Type in URL, click bookmark or shortcut (anything that directs me from the home page)
  3. “Establishing secure connection…” message
  4. Unable to connect (eventhough the site is up, since I’m able to ping it or open it on another browser such as microsoft edge)

Actual Result (gifs and screenshots are welcome!):
The site doesn’t load. I then restart the browser until it eventually works (this can take hours) or use another browser.

Expected result:
I expect the site to load.

Reproduces how often:
Multiple times a day (5 - 10 times)

Brave Version(about:brave):
0.58.21

Reproducible on current live release (yes/no):
Yes

Additional Information:
I do sometimes experience issues with my internet in general, but not as often as this issue occurs, and I don’t see how the lack of internet is classified as a security issue anyway (+ other browsers work).

#2

@kehvler,
Sorry for the late reply - thanks for reaching out and for the detailed write up of your issue!
So I’m not sure I’ve ever seen this particular issue before but I have a few things we can try off the top of my head:

  1. If you’re connected to a VPN, try disabling the VPN and browsing in Brave. If you’re able to browser without issue; close Brave, re-enable your VPN connection and return to browsing. If the issue appears again after reconnecting via VPN, we’ve likely narrowed that down as the root cause.
  2. Try disabling HTTPS Everywhere and then browsing. This is to see if there’s a conflict somewhere when Brave tries to connect to a site with an encrypted connection. To do this, open the main menu in Brave, navigate to Settings --> Brave Shields Defaults and toggle off the HTTPSE option.

Let me know the results of testing the above. Additionally (should you return), a screenshot of what it looks like when you receive that error message would be helpful. Also, Windows 10 or Windows 7 OS?

#3

Hello, thank you for the reply. I really enjoy using this browser and would rather not switch because of this issue.

  1. I do not use a VPN. I only have a browser-based extension which is off most of the time (I presume that’s not the kind of VPN service you were talking about).

  2. I tried disabling HTTPS now and at first I got the same error, but as of right now my browser is working as it should. I will keep an eye on whether this is a permanent fix or not.


Usually when the error appears the window is just gray as if it already started loading the page. The page failed to connect and displayed an error message right after, which I failed to screenshot since the issue suddenly fixed itself.
Also, as you can see I am using Windows 10.

Edit:


The problem occurred once again. On the taskbar you can see that I’m simultaneously using Microsoft edge, which is working as intended.

#4

@kehvler,
Can you tell me what extensions you have installed? Also, does this happen for any given website or are there particularly frequent offenders?

#5

The extensions are called Safe Torrent Scanner and Unlimited VPN. The issue occurs with any site.
The issue might reside with my internet after all though, I notice the connection frequently switches to a metered connection (connection is established but no internet).

Still doesn’t explain why other the browser worked while brave didn’t. I’ve also noticed some forum discussions about a similar issue but with chrome, found no conclusive answers.

1 Like
#6

@kehvler,
I’d recommend disabling the VPN and Torrent extensions for a while and see if everything stabilizes. We’ve had some issues with extensions (simply by being installed) and Brave not playing nicely and I’m wondering if this may be the issue.

If you’d like to skip that option and try another let me know.

#7

@Mattches
I’ve disabled the extensions and I encountered the same issue as before. Although I did start seeing this problem after installing said addons (not immediately), the issue seems to reside with something else.
Also, I noticed today that while the browser was supposedly establishing a secure connection it resolved as soon as I opened Microsoft edge.

#8

Can you check your Windows network settings and see if your VPN extension set up a virtual network of some kind?

#9

I’m not entirely sure how I would go about checking that, sorry.

#10

@Mattches Again, how would I check whether that is the case or not?

#11

Apologies for the late reply.
The virtual network should appear in your network connections/adapter settings on Windows 10 along with your other connections.

#12

No worries. There seems to be no virtual networks though.
Also, just in case this should be mentioned, I use a wifi adapter (Qualcomm Atheros).

closed #13

This topic was automatically closed after 30 days. New replies are no longer allowed.