Cannot open any hyperlinks outside of the Brave browser

Description of the issue:
Cannot open any hyperlinks outside of Brave with Brave installed

How can this issue be reproduced?

  1. Click on a hyperlink outside of Brave.

  2. See screenshot below:
    Brave troubleshoot

Expected result:
The URL should be opened in Brave.

Brave Version( check About Brave):
Version 1.25.68
Chromium: 91.0.4472.77 (Official Build) (64-bit)

Additional Information:

  1. The above message also pops up when I try to set Brave as my default browser in the browser’s Settings.

  2. In “Control Panel\Programs\Default Programs\Set Default Programs\Set Program Associations”, can’t set HTTP or HTTPS to be opened in Brave by default.

  3. I’ve tried reinstalling Brave, but the issue persists.

  4. Windows 8.1, 64-bit

Thanks for reaching out.
On your PC, can you go to

C:\Program Files (x86)\Brave Software\Brave-Browser\Application

and check to see if there is a Brave “application” file found here?

Yes, there is one. What should I do with it?

Nothing yet – I was just confirming that it was there.
So you’re saying that if you go to (in Windows) to Default apps and click on Web browser, Brave does not appear as an option, correct? If so, do other browser appear?

I’m not sure where “Default apps” is, but it does show up in “Set your default programs” in Control Panel.

Oh right – you’re on Windows 8.1 I forgot.

Okay so can you try going to Control panel --> Programs and under Default programs select Make a File Type Always Open in a Specific Program. Find HTTP/HTTPS – can you set Brave here?

I just re-read your first post and I’m not actually sure whether or not

Control Panel\Programs\Default Programs\Set Default Programs\Set Program Associations

Is the same as the option in my previous post.

I actually can’t find HTTP/HTTPS there. It doesn’t seem to be there:

Also, what’s weird is that this issue only occurs on my current computer. My other computer, which has Windows 8, doesn’t have this issue with Brave.

You don’t see HTTP/HTTPS when you scroll up on the screen in your last screenshot? It appears to be alphabetically ordered.

no, it’s not there:

I should also add that I never had this problem before I switched to Brave (I used to use Chrome)

Well this is on me partially – I said HTTP/HTTPS when I meant .html/.htm. And I do see that Brave is set to be the default application for those file types. Can you tell me where exactly you’re trying to open these links from?

basically every hyperlink that’s outside of the Brave browser itself

for instance, this is me trying to open a link to a webpage inside the Steam desktop app:

Hi, just sending you another reply in case the ones from last week didn’t show up for you.

Apologies – still catching up after the weekend.
Can you please try changing the default browser to another browser and tell me if you get the same results?

yes, still the same problem

So you get the same result when you change your default browser to another application? If that’s the case then this is looking more like a Windows/system issue rather than an issue specific to Brave. Let me dig around to see if I can find other Windows users with this issue.

1 Like

Yeah, I don’t get this issue on my other computer, which has Windows 8