Brave will not open hyperlinks clicked in other applications

When a hyperlink outside is the browser is clicked Brave does not open. If Brave is already open it does not open the link. This also happens when something is clicked in another application that should direct to a particular URL, for example a game’s site in Steam or clicking the Plex icon in the systems tray. The only way I can get it to work is by right-clicking and copying the URL and pasting it into Brave. Hyperlinks clicked in Brave work fine:
How can this issue be reproduced?

1.Click a hyperlink or something else that should open the browser and redirect to a certain URL.
2.Nothing happens.

**Expected result: Brave should open to the specified URL.

**Brave Version( check About Brave): Version 1.17.73 Chromium: 87.0.4280.67 (Official Build) (64-bit)

Additional Information:
Windows 10 Home 64 bit. Brave is set as the default Browser. It is also set as the default for HTTP:// and HTTPS:// protocols. When the default browser is changed to Firefox or Edge clicking hyperlinks or outside applications works like normal, hence why I suspect it’s something with Brave causing this. I appreciate any help you can provide.


EDIT: I tried uninstalling/reinstalling it again but this time around also deleted the local content. That seems to have done the trick.

I am having a similar problem. A hyperlink that should enable me to send someone an email from their site doesn’t open. I can’t even copy it. It’s happening with every online site email address that I try.

I only started having this problem in the last several days.

I’m also in Windows 10, 64 bit w/ Brave as my default browser. I haven’t tried setting another Browser as my default. But when I click on a site e-mail address in another browser, it takes me to the Brave homepage.

Brave… help us out!

Sorry to hear that! It’s been an issue for a while for me but I’m finally getting around to trying to fix. Hopefully Brave will be able to help us out.

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.