Bug: Mute Tab Button and context menu entry are not synced

When I’m on Web WhatsApp (https://web.whatsapp.com) and I get a lot of the annoying notification sounds I click on the tab the “mute tab” icon to mute the website. If I use the context menu on the tab to “unmute” the website the mute icon is not synced with the current setting of mute/unmute. If I use the icon to mute the website it doesn’t have an effect. Have to click it 2x in order to actually mute it. The context menu mute and the icon mute should always be synchronized.

1 Like

I agree completely. Though I’ll say I’m real simpleminded on things like this. To me it’s like, “who the heck uses the context menu anyway? And why?” It’s like, a single click on one icon rather than multiple clicks for context menu always seems better. Perhaps a bad mindset to have, but is kind of how I work on this.

So with me just being curious, why do you use the context menu despite it being extra steps? (Not saying doesn’t need fixed or anything, just curious why the extra steps when quicker/easier using a different method)

Umm, @Mattches I sometimes wonder about whether I should learn better to submit issues to Github and all. But wanted to tag this to you as I’m assuming you’ll better know who to forward this on to or create an issue yourself. Last time I tried to create a Github, issue just sat there with no movement.

Similar topic also was recently made at Brave browser is muting tabs without my permission

1 Like

Send me a DM about the Github thing and we can discuss.

Let me reach out to the team about this — I do see the same behavior on my end and I do agree that these options should reflect one another. Will reply here when I have more information.

Scratch that — looks like the issue is known and has already been reported here:

Went ahead and added your report as a +1 to the issue.

1 Like

The reason why I’m using the context menu is because the mute button is only clickable when there is a sound being played in the tab. WhatsApp notification sounds are very short, just a little “plop” sound. It’s impossible to reach the mute button during those few milliseconds the sound is played. You could also make the mute button longer clickable after the sound and I guess that would eliminate the need for using the context menu item.
Or maybe have a mute button somewhere next to the URL field where it’s always available to click.

1 Like

Yep, that’s a common sense one that I wasn’t thinking of when reading and responding right away, lol.

Just so you and anyone else who pops in here can be aware, it looks like this isn’t going to be changing any time soon. According to the Github that Mattches linked to, this is something upstream as part of Chromium. It’s labeled P5, which is: Not scheduled. Don't anticipate work on this any time soon. Again, the reason is Issue is in Chromium; we'll likely wait for the fix

I see that they have some similar issues open within Chromium bugs, but no idea when they (Chromium team) will work on it.

1 Like