Brave browser is muting tabs without my permission

I was watching a YouTube video a minute ago when suddenly, the tab was muted.
I cannot unmute tab, when I try to unmute it, the browser acts like the tab is unmuted when it’s not.
image
How do I prevent this from happening?

Well, what might be causing it is something I can’t directly answer yet. If I were allowed to make assumptions, I would assume you clicked on the tab and muted it without recognizing it. But that’s only because I’m not aware of a keyboard shortcut to mute it and I know there clicking the tab to mute/unmute is independent from that right click and then selecting Mute Site.

To better clarify, you see how your screenshot has the speaker icon with a slash through it, to show it’s muted. If you left click on that, it will unmute it.

What’s interesting is when you click on the speaker icon on the left side of the tab to mute/unmute, it won’t update in the Mute Site/Unmute text.

New Tab - Brave 8_5_2022 12_04_26 AM

So when muting/unmuting tabs, I wouldn’t use the right click option and would just click the speaker icon each time.

Now, if it’s randomly doing it without you clicking…then that’s something else we’re going to have to figure out somehow. But I wanted to start off with that portion at least and see if it can be ruled out or if perhaps you were clicking that to toggle between tabs or something.