Bug in detecting default browser

at every start up, brave claims that it is not the default browser, and asks to become default. This is different from this bug

were the proposed solution was to reduce the frequency of asking to become default browser. The reason why it is different is that I have already set Brave as my default browser, so the bug is in failing to recognize the setting.

I am using Version 1.48.158 Chromium: 110.0.5481.77 (Official Build) (64-bit)
on Ubuntu 22.04.1.
If I go to Settings/Default Applications in Gnome, I can see Brave as default browser. Also, no matter how many times I click on the button to make it default, it will always ask next time. I also tried to do this in Brave settings/Make default, but nothing happens when I click on the button. This started a couple of weeks back, so the bug seems to have come with some recent upgrade.

Hello @giampierosalvi

Thank you for reaching out and I’m sorry to hear you are going through this. Could you please use other chromium based browser to see if the issue persist?

Be waiting for your response!

I tried chromium, but it does not ask to become default regardless if it is set as default or not in the system settings. On the other hand chrome behaves as expected: if it is set as default in the gnome setting, it does not ask anything, if it is not set as default, it asks to be.
Hope this helps debugging.

Hi @giampierosalvi did this happen when you updated to 1.48 or was it already an issue?

Hi @steeven, I noticed it two/three weeks back, but I am not sure about when I updated the latest version. It seems to affect the version given trough snap on Ubuntu. I tested on two different machines both with Ubuntu 22.04:

  • on the first machine I have the snap version of brave (executable called “brave”) with
    brave --version
    Brave Browser
    This version IS affected by the bug
  • on the second, I have the apt installed version (executable called “brave-browser”) with
    brave-browser --version
    Brave Browser
    This version does not seem to be affected.

I tried snap refresh brave on the first machine, but there does not seem to be a newer version on snap. Also, I don’t know if the problem is with the version, or perhaps with the policy for snap packages. I recall that snap packages cannot access files in certain directories for security reasons, whereas apt packages can. Perhaps the snap package is not able to read/write the configuration file that defines the default browser? It’s just a thought.


This topic was automatically closed 60 days after the last reply. New replies are no longer allowed.