Browser not recognizing paid subscription status

Please provide us with the following information

Win 11 desktop pc, Browser version 1.50.151

I have an active paid subscription for VPN. It works on my mobile device and also used to work on my desktop. But now it stopped working on the desktop. When I click the VPN button, I get the ‘Buy VPN’ pup-up. When I choose the ‘already purchased VPN option’, I log in and I get the message about ‘VPN credentials are loaded on this device’. But I still can’t turn on the VPN, the ‘Buy VPN’ pop-up just stays. Refreshing the subscription didn’t work. I also tried setting the experimental VPN flag to ‘enabled’ but that also doesn’t do anything.

Could you try in a new profile?
From the hamburger menu → click on new profile

Creating a new profile unfortunately didn’t make a difference

Hmm. I will tag @GuardianTeam on this. They will assist you better.
BTW, when you said you use it on your mobile as well, makes me wonder if you purchased it through the play store / App store ?
If not so, could you login to and check if everything there looks alright ?

1 Like

Using the link you provided I can see that a subscription is active. I purchased through the App Store indeed, on the account page it says correctly ‘Purchased on iOS’.

@sweeeeep did you set everything up according to ?

1 Like

Yes I followed those steps. And after that it worked for a while, but now it somehow stopped working. Should I maybe purge some local Brave files or something?

@sweeeeep guess I was hoping it just was disconnected and if you went to try it again, would work (I know you mentioned doing it in original post, but hoping maybe trying after a restart or something is all that mattered). But if you’re saying that’s not the case, I’ll tag @Mattches on it. In terms of troubleshooting for VPN, I’m not quite sure where they start.

1 Like

Can you please disable the flag and test again and confirm that it is still not working? Would prefer to ensure that this flag is disabled to ensure there’s no weirdness due to having the feature enabled by default and the flag set to Enabled.

Will reach out to the team with this either way.

1 Like

I disabled the flag (put it back into default), still no change though.

Just to update, I believe we have discovered the issue and are working to get a fix uplifted into the browser. More information on this as soon as I have it, thank you for your patience.


Alright, that would be great of course!