Browser not opening after it didn't closed properly

Description of the issue:
I am closing the browser like normally through the x in the upper right corner. Now when I close brave, I can see the processes in the task manager moving from apps to background processes. (Site note: despite only having one tab open there are currently 8 processes running.) When I try to reopen brave again that doesn’t work. At least not until I manually go into the task manager and delete all pending brave processes in the backround. If I open brave then it works but displays that it didn’t closed properly and offers me to restore my tabs. The same happens the next time, over and over again.

What did I try to solve the issue?

  1. I disabled all addins
  2. I disabled hardware performance boost
  3. I disabled keep on running apps in background after closing brave
  4. I restarted the laptop

Brave Version:
Version 1.44.112 Chromium: 106.0.5249.119 (Offizieller Build) (64-Bit)

Additional Information: its a new windows 11 pc and I didn’t experience something while using brave on my old device before. My device is running in German so some translations might be not exactly like in the english version. I’m new to this community so looking forward to understanding and some not-deeptech help. Have a nice day!

Could you check the above topic to see if it helps ?

I’ve experienced this too, albeit with an earlier version of Windows: for no specific cause to which I can point my finger, when I close / exit Brave, subsequently, I can’t re-launch Brave. For me, this has happened very rarely, but that’s more frequent than ‘never’. My pattern of use is that simply re-booting my computer is no inconvenience, and that has invariably resolved this issue. Most recently when this occurred (unable to re-launch Brave), like you, I checked Windows Task Manager and, like you, I found multiple Brave-related processes listed. I closed these processes and was then able to re-launch Brave.

@SmartyAadi: the topic you suggest may or may not relate to this issue. It doesn’t resolve it; merely links to other comments that are less-related to this issue. Also, the suggested resolutions appear to me to be more obscure and complex than either using the Windows Task Manager to stop Brave-related processes or simply re-booting.

Repeating: for me, this has happened very rarely. I’ll make a mental note: next time this happens, I’ll make a record of the specific Brave-related processes I find unclosed.

Thank you for idea, SmartyAadi. It didn’t worked. Maybe because it’s different in that term that if I get to open brave everything works as normal. Only opening the browser is challenge through these background processes that are still on.

Imma Tag someone who might be able to help @rodrige @Aman_M @Alice2095 @Kevin_cc @Jarc-1107

Thanks so much for sharing what possibly helped in your case. That helps other users to help themselves!

Thank you so much guys for your quick and good help, @redbike9 and @SmartyAadi. My workaround now was simply to deinstall and reinstall brave. Now everything works smoothly again, even with addins and the other things on. To anyone else that could experience something similar: only updating the browser didn’t work for me. I had to deinstall.

1 Like

That’s great. Thanks for sharing the solution!

@sirhc2000 I also experienced this before. But for me, an update used to be pending brave://settings/help whenever it used to happen. So after force closing and first thing getting the update complete, had worked for me.

1 Like

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.