Brave Crashes as soon as opened

Description of the issue:

Switched to Brave Browser about a week ago and made it my default browser. Put my machine (Windows 64-bit) to sleep last night. This morning found that the Brave browser was closed. When I tried to reopen it, it opened, with a pop-up showing that Brave was not closed properly and asking if I wanted to reopen closed tabs. As soon as I clicked on yes, the browser closed. I tried reopening the browser, but it would close within 3 - 4 seconds of being reopened.

I uninstalled the browser and restarted my machine. I then reinstalled Brave by downloading the 64-bit installer from the Brave site. The problem persists - i.e., the browser crashes after a few seconds of being opened.

Steps to Reproduce (add as many as necessary): 1. 2. 3.

    1. Open Brave browser
  1. Browser crashes
  2. Restart machine
  3. Reinstall browser
  4. Open browser
  5. Browser crashes

Actual Result (gifs and screenshots are welcome!):

Unable to capture screenshots as browser won’t remain open.

Expected result:

Browser should stay open

Reproduces how often:

Each time the browser is opened, it crashes.

Operating System and Brave Version(See the About Brave page in the main menu):

Operating System: Windows 10
Brave version:

Additional Information:

Thanks for this will try to replicate the same actions


I’m stumped. I looked around the community site and I found an issue that was happening in Dec 2018 where the problem was a blank screen occurring.

The Dev @Mattches had the following workaround that seemed to work for people running Win 10 64: Error on yesterday’s update [Windows “blank window” issue].

The solution involves disabling hardware acceleration. It seemed to work for some people, but when I tried it, the browser wouldn’t stay open long enough for me to go into settings and disable hardware acceleration (if indeed it’s selected - I didn’t enable it).

Any other solutions you think I can adopt?


@Mattches, @Dgenies

I managed to take a screenshot of Brave before it crashed.

As you can see, the only extension I have installed is Lastpass. Brave doesn’t stay open long enough for me to disable or install it. Any help you can provide would be highly appreciated.


I uninstalled Brave (0.63.55) and I downloaded Brave Beta (0.65.88) and it is working on my machine. As I didn’t receive a response, I assumed that the problem was machine specific. If I remember to do so - or if I run into issues with the Beta (0.65.88) version - I will install the Release version (0.64.x) on May 14 when it is issued.

sorry yesterday Brave was flooded with reward and publisher claims. @Kimenyi am really sorry

@Dgenies, no worries. I found a solution and I’m still using Brave! Hopefully, the same issue won’t recur in the 0.64.x release version.

@Dgenies @Mattches

I installed the 0.64.x release version this evening. The same thing happened. I uninstalled it and I’m back to using 0.65.88 Brave Beta (I never uninstalled it). Any idea why this is happening? Will I have to use Brave Beta from now on?

1 Like

you could wait till version 65 is released. sorry this happened

Very strange behavior – I’m assuming you’re on Windows 10, correct? Can you tell me if you have any anti-virus services running in the background (if so, which ones)?

Additionally, can you try disabling Hardware Acceleration? Normally this is done in settings, but since you can’t keep the browser open, try editing the shortcut path as explained in the solution here:


I am on Windows 10 and I’m using Windows Defender as my anti-virus. When I used the method in your solution, Brave still crashed and I kept opening it until I could open settings and I checked and hardware acceleration was not enabled.

I uninstalled Brave 64 (May 14 update) as I couldn’t keep it open. I’m now exclusively using Brave 65 Beta as it doesn’t crash on me.

[Edited to elaborate on hardware acceleration issue]

Thanks @Dgenies. Once Brave 65 final is released, if it doesn’t work, I’ll continue using Brave 65 Beta.

1 Like

This topic was automatically closed after 30 days. New replies are no longer allowed.