Brave works than it doesn't

“C:\Program Files\BraveSoftware\Brave-Browser\Application\brave.exe”
“C:\Program Files\BraveSoftware\Brave-Browser\Application”

Description of the issue:

• I have 3 computers and it’s the same with all 3. Brave is installed and working. Suddenly the next day I turn my computer “ON”, Brave doesn’t open anymore. I remove Brave from my computers, do a restart, clean histories and cookies with CCleaner, Internet Option and This PC properties clean the disk. I defrag from time to time, but the cleaning is done every day when I turn “ON” my computers. I don’t have this issue with Chrome, DuckDuckgo, or Firefox. It’s hard to keep Brave up and running from day to day. Is it because I overclean my cache, history and cookies that could be doing this? It doesn’t happen with the other browsers.

Steps to Reproduce (add as many as necessary):

• Remove Brave
• Restart computer
• Do a full cleaning of caches, history and cookies.
• Re-download Brave.
• Re-install Brave.
• Re-start the computer again.
• Sometimes it works, sometimes it doesn’t.

Actual Result (gifs and screenshots are welcome!):

• All are explained above and below.

Expected Result:
• Brave to work and remain working like it used to but not anymore.

Reproduces how often:

• Very often on all 3 of my computers.

**Brave Version(about: brave): 126.1.67.119

BraveBrowserSet-up-BRV029.exe
BraveBrowserSet-up-BRV030.exe

Reproducible on current live release (yes/no):

• Don’t know

Additional Information:

• It never used to do this, it started about a year ago. It seems to happen when there is a Windows update but then I paused them, and the problem still remains. I am about to toss Brave into the recycling bin if you don’t offer a permanent fix and will go back to DuckDuckGo which also doesn’t sell your info to third parties, but I prefer Brave, I can do more with it than any other Browsers.
• I am an avionics-electronics technician by trade with 35 years of experience and know how to use a computer.