Brave Wallet wont import from Metamask

Tried to set up the Brave wallet from my Metamask and it wont accept the password. Yes, the password is correct. All I get is ‘JSON data is not expected’. Tried it a number of times but no joy. Doesn’t fill me with confidence to use the wallet.

1 Like

It’d be best in your case to just to create a new wallet and don’t try to import from MetaMask. You can do this from brave://wallet.

Thanks but no point in doing that. I’d have to pay to move my crypto between wallets.

I see, I thought maybe you had not setup MetaMask.

Would you be able to run brave with these command line arguments:
--vmodule=brave_wallet_service_delegate_impl=3 --enable-logging=stderr

And then send us the log? Thank you.

I don’t think there’s any private details in the log but please double verify before sending anything in through support.

I’m getting the same thing, i.e., “JSON DATA IS NOT EXPECTED”. My first question is:

  1. if we already were using Braves in browser MM wallet, do we need to import?

Seems like every time Brave upgrades the wallet or browser, it breaks something. I have some ETH in my Brave Wallet currently so my second question is:
2. will this delete any of my funds?

My 3rd question is:
If I don’t import (can’t at the moment since I’m getting that JSON error), why am i forced to input my recovery phrase?

I think you’re on the wrong screen. You want to click Get Started on the first screen, then at the bottom there’s a link to make a new wallet. It’s easy to miss.

See https://github.com/brave/brave-browser/wiki/Wallet-support-FAQ#i-want-to-create-a-new-wallet-but-i-dont-have-a-password-for-the-existing-wallet

Thanks. I tried using the command but all i get is command not valid. I opened properties and inserted your command into the target box after the quotes as per Brave help.

We have some import refactoring in 1.35.x but that isn’t due until February 1st on Nightly.
Maybe you could just restore from recovery words to Brave Wallet.

This topic was automatically closed 60 days after the last reply. New replies are no longer allowed.