Unresolved: Cannot restore wallet

I made a wallet 1-2 years ago and loaded it with some eth, and forgot about it. I normally run google chrome but had downloaded brave to have a second browser going at the same time. Anyways, I tried logging in with the password i wrote down, and it said password is incorrect. OKAY, weird since the password hasnt changed. I go to restore it with my 12 words, and when after entering the phrase along with my new password have no problems. It immediately prompts me to log in (with my new password) and when i try to use that it says its incorrect.

I do not believe this is a user error because I tried multiple times to make a new password when restoring but every time it said incorrect.

What am i doing wrong?? why doesnt it work? Can i use my seedphrase to import in metamask?


Can you reset the wallet completely and then use the Import Existing Wallet option instead?

Once reset, try importing the recovery phrase with these instructions below.

Please note, Brave can NOT access your wallet or reverse a wallet reset. The recovery phrase is the ONLY way to regain access if the wallet is reset.

Please let me know if you have any questions.


1 Like

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.