Brave wallet unable to add cronos rpc network

Unable to add the new RPC network “cronos” from chainlist nor adding via manual setup following the official doc (link). Problem is that brave network configuration does not accept a chainID that is not hexadecimal. Do I need to convert the decimal to hexadecimal manually ?

try going to https://anyswap.exchange/ and selecting it as a network in the top right. Worked for me

Not working for me, switch back automatically to ETH mainnet.

I get a prompt to add the network to the list of networks in the settings.

after it looks like this

Do you see it in your list of networks now in brave://settings/wallet and in the network selector in the wallet icon?

I added cronos from chainlist.org and it worked great.

If not maybe you have another wallet installed that overwrites window.ethereum. You can force it to use Brave Wallet instead in brave://settings/wallet by changing the default wallet from "Brave Wallet (Prefer Extensions) to just “Brave Wallet”