Cannot add BSC Network

Description of the issue:
I cannot add BSC network to the new Brave wallet. I have tried it via Chainlist and via the default values available in brave://settings/wallet/networks.
For Chainlist, I connected brave wallet, it connected normally and shows that chainlist adding bsc to brave wallet, but I cannot see BSC chain in the network interface. It just shows Eth and Eth test nets and localhost.
From browser settings, I clicked on ‘Set as Active’ for BSC and nothing happens.

Are you using the (new) Brave Wallet or the (old) Crypto wallets implementation?

How can this issue be reproduced?
I used this new brave wallet last year (or few months back) and via chainlist I was quite easily able to add BSC within few seconds and connect wallet to Pancakeswap and do some stuff on the DAPP. But, now, I am able to do it.

Also, for some reason, I do not see anything related to Solana in this wallet.

Brave Version (check About Brave):

Additional Information:

well now, on chainlist it gives and error when I do ‘Add to Metasmask’ for BSC or any chain even ETH Mainnet. The error is ‘The method ‘wallet_addEthereumChain’ does not exist / is not available’.

Hey @chh_68, happy to help! :slight_smile:

It looks like you are using our depreciated Crypto Wallets.

To switch to our new Brave Wallet, go to brave://settings/wallet and change

Default Ethereum wallet to Brave Wallet
Default Solana wallet to Brave Wallet

Now go too brave://wallet and from there you will be able to import your old Crypto Wallet to the new Brave Wallet where you will be able to use the BSC network and Solana network from settings.

Hope this helps!
Douglas Daniel

I think I am on the new wallet and not on the old deprecated wallet. I am on Linux btw. Previously I had chosen Brave Wallet (Prefer Extensions) for both Eth and Solana and now only Brave Wallet in settings but nothing happens. On chainlist it is still giving me error.
I even did a reset and re-typed my seed phrase to solve this problem, but the same thing happens.

If I still on the old wallet (according to the screenshots), I am unable to get on the new wallet.
I did not use the wallet on this device ever, so when I enabled wallet yesterday, it started downloading ‘components’ for few seconds and then the wallet loaded. So, did it accidentally download components for old wallet instead of new wallet from brave’s servers even when I mentioned from settings to download components of new wallet.

I have solved it.
Previously, I had changed some flags in which I had disabled Brave Walllet via brave://flags.
I just remembered that I had disabled the flag, turned it ON now and the new wallet is loaded and works just fine.
I also see other chains (solana default), ETH mainent, BSC and other chains.
Everything works just fine.

I had also blocked Etherum Provider API from brave://settings/content/ethereum, that is why the old wallet was not working with chainlist (even if it was deprecated it should have worked). I have enabled it now.

The problem was on my end, as I had disabled the flag. Problem has been solved.

1 Like

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.