Brave update, download, and re-installation not progressing

I have tried updating to the latest version on my laptop.

Upon clicking the update icon in the top right of my Brave browser, I was redirected to the chrome (chromium) update download page, for chrome browser, repeatedly.

When trying to update through the Brave menu in the About Brave selection in the dropdown list, the check for new version failed repeatedly, referring me to the help community site (here).

Trying to download a new version from directly does not move past the “downloading” stage, and does not download at all.

I have since uninstalled brave to see if this would allow the download to begin uninterrupted, it has not. I am unable to move past “downloading”.

I have also tried disabling my firewall and anti-virus (kaspersky), no changes here.

I am currently unable to download brave, period.

Welcome, @Nebulous.

The chrome:// page you see in Brave is okay; because Brave is based on the Chromium code, some of the settings pages and such will have the chrome:// prefix instead of the brave:// prefix. As long as it’s the local one (chrome://) and you’re still in Brave, you’re fine.

Kaspersky can interfere even when you disable the AV component, maybe even when more functions are disabled. Basically, it seems Kaspersky flags and interrupts Brave updates on a fairly regular basis. Here is a post from a related thread that has links that may help.

One thing you might try, on the theory that it’s the Brave installer’s trying to download additional software that triggers K’s interference, is to download the standalone installer mentioned by @Mattches in this post.

Here’s a direct link to the current 32-bit version of Brave 0.65.118:

Here’s a direct link to the current 64-bit version:

For the whole list of the current release’s available files/installers, see

1 Like

Excellent support! Please ping me if your solutions don’t resolve the issue – but it looks like you have it handled? :slight_smile:

1 Like

The direct download work linked, I couldnt find it on my own, thank you!