Can't upate or check for updates in Brave

windows

#1

I have version Version 0.56.12 Chromium: 70.0.3538.77 64 bit and when checking for updates it says " An error occurred while checking for updates: Unable to connect to the Internet. If you use a firewall, please whitelist BraveUpdate.exe. (error code 7: 0x80072EFD – system level)," I tried disabling my firewall as well and nothing, I even downloaded the latet exe from the site and ran that and got a no internet connection error, I can’t uninstall because if I do that I doubt I could reinstall, I even tried running as an admin!


#2

Hi, I had the same or a similar problem myself. My problem was that I could not update to the latest Brave version with my standard account.

Try it, not only “Run as administrator”, but also log into the administrator account and start the update from there.

Good luck :slightly_smiling_face:


#3

Tried that, same issue, with auto update and program download.


#4

You didn’t mention which version of Windows you’re running. I’m using Win 7 (Service Pack 1) both 32- and 64-bit installations and what follows refers to that; other versions of Windows: who knows?

A few alternatives to suggest. Specific to two laptops that see use in settings with broadband access that’s reliable but limited, I’ve disabled Brave-related autoruns that must be re-enabled to run updates.

Both desktop and laptop installations (these are all Brave / Chromium , not Muon – similar to what you describe): sometimes, clicking “About Brave” – which I think should fetch an update if one is available – fails. What has worked reliably: reinstalling Brave using the appropriate “Download” link on the Brave home page https://brave.com/ “Worked reliably”: the latest version is downloaded and installed while retaining my preferences and bookmarks. YMMV.


#5

Windows 10 latest version 64 bit on Standard user account tried on the Admin account as well, same issue. Using the Chromium version of Brave.


#6

@Dan50,
Do you have any Anti-Virus software enabled on your Windows machine?


#7

Comodo Internet Security but nothing is blocked that I can see.


#8

Hi, I used Comodo many, many years ago. Had there either now and then or almost always problems with. Try deactivating your Comodo for the update and see if it works. :unlock:


#9

I have still nothing.


#10

Can you try installing the Brave Beta build?