Brave Unable to Relaunch

I just updated to Win 10 2004. Brave works fine, except when I close it and try to relaunch it a few minutes later, Brave will not open. The only way I can get Brave browser to open up is to restart my computer. This does not happen all the time, but I will say it happens about 90% of the time. Very annoying. Does this happen to anyone else? What is the fix if any? Any help is deeply appreciated! Thanks!

1 Like

“restarting” your OS is a bit extreme.

I suspect you have a rogue Brave process running … your description of
“i quit Brave and try to restart and it does not show” is not an uncommon issue, though it rears its ugly head for a very small minority of folks.

Next time, after you quit Brave, open Task Manager and see if there is a Brave process (or two or more) still running. If you see rogue Brave processes, kill them and attempt to fire up Brave … should work.

Let us know.

1 Like

Thanks cauldercay! Next time Brave relaunch fails, I will check for rogue Brave process on Task Manager and let you know. Great community!

1 Like

Hi - So had another instance where Brave would not relaunch. Followed cauldercay’s instructions to check task manager for rogue processes running. I killed then and Brave opened up normally. No more needed to reboot computer. Thanks again cauldercay!

Thanks cauldercay! Next time Brave relaunch fails, I will check for rogue Brave process on Task Manager and let you know. Great community!

1 Like

.
Do you have this setting turned ON (Settings -> System -> Continue running …)

image

1 Like

Yes. It is turned ON

1 Like

If you have time to experiment, you could turn that setting off and see if Brave shuts down completely and you’re able to start it up as expected.

1 Like

Thanks! Great - will give it some experimentation and report back!

2 Likes

Hey @caldercay, per your instructions, I turned OFF “running background apps” and Brave was working fine for a couple of weeks. However, just now, Brave refused to open after I shut it down to go to have some breakfast. Went to task manager and got rid of the rogue apps running and was able to open the Brave Browser.

Thanks! Great - will give it some experimentation and report back!

1 Like

So … did the setting revert back to ON ??

1 Like

No, I turned it off as per you suggestion and it remained off. So I had the issue with it both ON and OFF Emoji

1 Like

Seems the Brave browser locks up more often when Continue Running Background Apps is OFF. Had it OFF for a about two weeks, and the lockup seems to happen more often. Just turned it back ON, and will see what happens.

No, I turned it off as per you suggestion and it remained off. So I had the issue with it both ON and OFF Emoji

1 Like

Hello @anotherconvert

are you comfortable with using some argument to start your brave with just for one time then you remove it
restart your windows

create a a folder in any place you like it

right click on your brave shortcut icon then properties then click on shortcut then on target filed after the " add one space then write the folowing --user-data-dir=c:\foo

you can replace c:\foo with the location to the folder you created earlier

then click ok then start brave

it will start like if it was a new profile and make sure to turn off the continu running in back ground as caldercay said then after 1 min close brave

then check that all brave process is stopped then
go remove the --user-data-dir=c:\foo that you write earlier then start brave it will load your old profile

now check if this help or you still have the same issue

hope that help and have a nice day :slight_smile:

1 Like

Thank you! Will give it a shot and report back!

| justsomeone1
October 31 |

  • | - |

Hello @anotherconvert

are you comfortable with using some argument to start your brave with just for one time then you remove it
restart your windows

create a a folder in any place you like it

right click on your brave shortcut icon then properties then click on shortcut then on target filed after the " add one space then write the folowing --user-data-dir=c:\foo

you can replace c:\foo with the location to the folder you created earlier

then click ok then start brave

it will start like if it was a new profile and make sure to turn off the continu running in back ground as caldercay said then after 1 min close brave

then check that all brave process is stopped then
go remove the --user-data-dir=c:\foo that you write earlier then start brave it will load your old profile

now check if this help or you still have the same issue

hope that help and have a nice day :slight_smile:

1 Like

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.