Brave taking up far too much memory even with hardware acceleration off

I currently have 4 tabs open and 9 extensions installed (all necessary) and Brave has 24 processes running, 9.5gb of my 16gb is currently occupied with 4 tabs open?! The number of processes outweighs the tabs and extensions, why is this?

I can’t stress enough how frustrating this is, if we can’t find a solution I’m going to have to annoyingly switch browsers again, but honestly other than this I love Brave

9.5gb is not even too bad, at least my computer runs like this, but super limiting and therefore frustrating. If I have more tabs than this open, memory usage reaches 95% and sometimes stalls out and crashes my computer. Just in the last week, this has begun to pop up.
Screen Shot 2022-11-25 at 12.32.52 pm

Now I usually have 10 - 15 tabs open and have done so for 6 months ish, why has this only started happening in the last week? I also had hardware acceleration on until yesterday, I turned it off but it hasn’t helped. Is it an update that is causing this? My laptop is a 2022 M1 macbook pro, this shouldn’t be happening. Please, whatever ya’ll have done, change it back

If this is all so that brave can segregate processes and avoid the whole browser crashing rather than just a single process, PLEASE give us an option to run it as 1, or at least less processes. Because it is not working as is, the amount of processes running ends up crashing my whole computer

EDIT. Forgot to mention that the ‘force quit applications window’ shows brave occupying far less memory than it is

→ More Tools → Task Manager to get a better breakdown of resources. More tabs, extensions will add to memory usage. Chrome memory usage will have similar usage here @tom3

Its hard to say if “462.6 Mb” is bad or not, since it depends on tabs/extensions.

Disabling HW acceleration will put more load on the CPU btw

Nice thank you for that, that does give a clearer view of what’s happening. My issue is that this has only just started happening to me, when i’ve been running the same amount of tabs/windows forever.

CPU seems to be fine most of the time, it’s my RAM that’s suffering, would you turn it back on?

Yes I would, was there a reason you disabled it in the first place?