Brave Summarizer not showing up in searches

Hi all! New guy to the Brave browser, which I’m excited about. One of the main reasons I wanted to try Brave was your awesome (at least to me!) Summarizer option. But my Summarizer never shows up in any search. I simply get all the results. I’m sorry to bother everyone, but I have researched and researched and can’t locate the issue. I also tried a clean re-install. No summarizer.
2022 Dell Inspiron 7706, 16 GB RAM, Windows 10 w/ all updates, Brave v1.51.118 (May 17, 2023), one tab and uBlock extensions. No other issues.

Thanks in advance

Hey there!
If you go to is Summarizer turned on ?

Hey there, SmartyAadi. Thanks for the reply. Yes, it is turned on. I even tried the old “turn off/turn on” trick. No deal.

Well. That is very weird. @Saoiray would you have anything that could help?

@dschmootz Summarizer is still in something of a beta and will not yield results every time. There doesn’t seem to be any clear method to the madness of what summarizer will and won’t show. It’s just a roll of the dice to an extent. For example:

Compared to:

Actually, why don’t you try who is the CEO of Brave? and see if it shows? I’m assuming you should get the same as below, if you have Summarizer turned on:


Thanks for your suggestions/explanation. Here is a screen shot of what I see. Maybe I have a setting configured incorrectly. As you can see, when I do have summarize, it’s just a blank square. This happens when opening a private window as well. I looked thru my settings and can’t see where I made a mistake in configuration.

@dschmootz I think I might know what’s going on. Can you look at your Shields settings? I think you have Block Scripts enabled. I turned it on, as you can see in the screenshot below, and it then looked exactly like yours.

But if you have Block Scripts turned off, it loads just fine.

You want to almost never have Block Scripts enabled, it breaks a lot of content. Only use it when necessary on sites that might display things you need blocked. But that should be very rare.

Thanks again. But “Blocked scripts” was unchecked. I turned it on, reloaded Brave, turned it off again and I still have the issue.

e. Tough one, right?

Saoiray, I got it! You steered me to the righty direction. I did a " Reset settings -
Restore settings to their original defaults". Now I have the summarizer. Thank you.

1 Like