Brave Shields is not working

My Brave Shields is not working to stop ads to any website although it’s active

Brave: Version 1.45.118 Chromium: 107.0.5304.91 (Official Build) (64-bit)

OS: ubuntu 22.04.1 LTS

Screenshot attached

1 Like

Start by going to brave://settings/shields and switch the adblocker to Aggressive.

Most of the time those ads you will see will be hidden through cosmetic filtering, they are not block or add anything to privacy or stop the tracking, but are annoying or leftovers.

But Standard only blocks third-party and Aggressive will block 1p and 3p.

Technically you should be blocking many connections like 6 even on Standard, and 2 more 1p when you enable Aggressive, so it is weird it is not working for you.
But start by switching the adblocker to the real mode, which in my opinion should be default one but it is not because Brave Team decided so, their reasons make sense but it is annoying to see these ads or leftovers or garbage in the page, even if it shouldn’t show that much garbage and block stuff, mostly Search Engine ads are the ones that are more like 1p vs 3p kind of thing, left overs and all are already removed when a 3p Network filter is applied on Standard.
But Brave did some difference between 1p and 3p so go and switch to Aggressive.

How long have you used Brave? Because you could go to brave://components and for the lists update by updating Brave Ad Block Updater that is the one in charge to push the Adblocking lists updates, so the only thing I don’t see adblocker doing anything is by not having lists to use.

You should write a custom filer in brave://adblock and see if that applies to the page, or just use a simple one *$script and see if that blocks all scripts in a page, because it could also be a bug with Linux or something, which would be worst than adblocking not working for you.

Does it block in private window mode, no extensions enabled? @immad299

I have changed the settings to aggressive mode but still its not blocking ads you can see the screenshot as a proof

Just tested it by also enabling the aggressive mode in private mode but still its not working see Screenshot


i

You should test in Private mode like Fanboy suggested and disable all extensions. One might be causing trouble there because this is weird that the adblocker is not doing anything at all.

Try again adding a temporary custom filter like I told you *$script in brave://adblock , to see if it is even blocking anything at all.

If you want try something more extreme: delete this folder %localappdata%\BraveSoftware\Brave-Browser\User Data\iodkpdagapdfkphljnddpjlldadblomo restart the browser, go to brave://components and update Brave Ad Block Updater it should say 1.0.87 or 1.0.88 or something like that in the version.
That will re-download the lists of filters so maybe there was an error or something downloading them. Or just go to components and see what it says, if it says like an error or 0.0.0.0 or something.

Also tested it by also enabling the aggressive mode in private mode but still its not working see and also added a custom script there Screenshots


image
l

image
Its giving error

Yeah something is blocking you the downloading of every update component.
I don’t know your computer so it could be anything, maybe firewall or DNS problem.

Also, don’t add Brave://adblock as a custom list though.
But maybe you can try adding the default lists Brave uses individually until you find out why you can’t download components and you see them updated.

not the most practical way, because custom lists only update after 7 days automatically, but here is the link https://github.com/brave/adblock-resources/blob/master/filter_lists/default.json
Just use every "url": entry you see.
Maybe that will work for now, maybe the updates will go through that way at least.

But that’s your problem, you can’t download the lists or any other component. So you should check your network setup or computer firewall or something like folder permissions in the User Data, to see why.

I don’t know how to help you there since I don’t know your computer, but now you know the reason, so you can find what’s going on.

As I mentioned earlier I am using the ubuntu 22.04.1 LTS official version and there is no firewall on it Network is working fine for all websites except this component not loading. how to ensure this in ubuntu 22.04.1 for User Data permission?

https://github.com/brave/adblock-resources/blob/master/filter_lists/default.json this method works for me thanks

Well at least that works, you still need to find out what might be blocking the downloading of components, it is not only the Adblocker lists, it is everything else, included resources which are scriptlet injections important to block and remove many ad and tracking related things.

But I can’t help you, I missed you saying you use Ubutnu though, so I admit that I gave a Windows path to test, so sorry about that!.

I probably blocked it from my mind because I think linux is the worst and a piece of crap and waste of time, so that’s why I won’t even pretend to help further.

The question is, how did you install Brave? there are 2 million ways of doing it, when I used Pop! OS, I used the terminal method of installing, not like a snaps or flatpacks or anything of that BS.
So depending how you installed them, the user data will be, I guess, in another place, when I used it for example I even transfered my User Data from Windows to Pop OS and it worked fine besides the encryption.

I used this to install my Nigthly version in Pop!OS when I tried if few months ago:

And my User Data was located in .config/BraveSoftware/Brave-Browser/User Data or something like that. Should be.
And all the subfolders you will see are mostly components downloaded that have an error, for example iodkpdagapdfkphljnddpjlldadblomo is for the lists, mfddibmblmbccpadfndgakiopmmhebop for the resources.
Can you even use Tor? Tor is also works like that, it downloads in cpoalefficncklhjfpglfiplenlpccdb

The Folder structure should be like this like on Windows, and you can try delete everything but the default folder (your profile), and Local State file and maybe they will be re-downloaded.

Snap version in the help says

You can find Brave in the Snapcraft Store, but while it is maintained by Brave Software, it is not yet working as well as our official packages. We currently recommend that users who are able to use our official package repositories do so instead of using the Snap.

So if you used snaps or flatpacks I would just install it like the Brave page says.

It is weird it is not working on your side, it should be downloading everything just fine.

Thanks for helping me out I have find this out on my ubuntu and I have delete everything but I try to install using that official command from brave web

sudo curl -fsSLo /usr/share/keyrings/brave-browser-archive-keyring.gpg https://brave-browser-apt-release.s3.brave.com/brave-browser-archive-keyring.gpg

this error appears in the terminal
curl: (6) Could not resolve host: brave-browser-apt-release.s3.brave.com
same happens with the nighty version too
The only way I can download from here
and its shows stable version you can see in the screenshot?


still components are not downloading

if it couldn’t resolve the host, it has to do with your DNS. Are you running some DNS that might be blocking brave?

That curl command even works on windows, and if you are not able to download brave updates (components) or even the keyring file, then that means you are just not connecting to brave, like you are supposed to.

That’s why Snaps can’t download components, even if Brave doesn’t officially support snaps and they say it is not too great, it shouldn’t be causing these problems.

It’s is something about your network then, that’s why first I mentioned firewall but if the host can’t be resolved it should be DNS related, if you can, try another one if you are using ISP, or see how you can set up your current one to stop blocking Brave, but it is a problem you have connecting to Brave domain.

I bet if you ping the apt address you might not get a response back, which in my case responded with an ip 18.64.174.0/24

But here you can see that I am able to ping this ip
image

Do it with the domain: ping brave-browser-apt-release.s3.brave.com

The IP changes for Brave servers, since they use AWS, so only pinging the domain will give the real IP, I just said /24 because it seems to give 18.64.174.X IPs although, it gave me a 18.155.248.45 for some reason the host couldn’t be resolved by terminal and you haven’t been able to download any component, while it worked when you added github urls as custom lists.

So you should try to test and resolve the issue why you can’t install Brave like Brave help tells you to install through the terminal and downloading the gpg so it can be installed easily.
Because even if you can install Brave through snap which seems to be unofficial and not stable, you still can’t download components there.

if I ping brave-browser-apt-release.s3.brave.com
then this error appears
ping brave-browser-apt-release.s3.brave.com
ping: brave-browser-apt-release.s3.brave.com: No address associated with hostname
but If I ping 18.155.248.45
it works

PING 18.155.248.45 (18.155.248.45) 56(84) bytes of data.
64 bytes from 18.155.248.45: icmp_seq=1 ttl=243 time=313 ms
64 bytes from 18.155.248.45: icmp_seq=2 ttl=243 time=313 ms
64 bytes from 18.155.248.45: icmp_seq=3 ttl=243 time=312 ms
64 bytes from 18.155.248.45: icmp_seq=4 ttl=243 time=312 ms
64 bytes from 18.155.248.45: icmp_seq=5 ttl=243 time=313 ms
64 bytes from 18.155.248.45: icmp_seq=6 ttl=243 time=317 ms
64 bytes from 18.155.248.45: icmp_seq=7 ttl=243 time=312 ms
64 bytes from 18.155.248.45: icmp_seq=8 ttl=243 time=312 ms
64 bytes from 18.155.248.45: icmp_seq=9 ttl=243 time=313 ms
64 bytes from 18.155.248.45: icmp_seq=10 ttl=243 time=312 ms
64 bytes from 18.155.248.45: icmp_seq=11 ttl=243 time=318 ms
64 bytes from 18.155.248.45: icmp_seq=12 ttl=243 time=313 ms

Well, I think you should test everything in your network, from switching DNS server to test in another network, maybe flush DNS cache and all that, I would even plug computer directly to modem, if you use a modem and a router separately and see if it works that way.

Even terminal threw the error about how it couldn’t resolve something about Brave domain, so it is not only components issues with Brave itself but you can’t even install it.
What even happens if you try to go to https://brave-browser-apt-release.s3.brave.com/ do you even can go to brave through it? when I go it displays a blank website with only https://brave.com/linux/ and then sends me there, so are you even able to use that link?

When I go to that link https://brave-browser-apt-release.s3.brave.com
I am able to see https://brave.com/linux/ so I can use that but the problem will remain same

well, but you still need to test different DNS servers and a different network or a VPN or something.
I am not a linux person, so I can’t say much about it.
When I used linux I used this one which can filter by app https://github.com/evilsocket/opensnitch
So it was easy to see which connection was a program trying to connect to, and then you can see how you resolve this issue.

You are simply not connecting to these Brave that are important, all components page does is to contact server, download a tiny file which is plain text and done, that’s the problem you have, but you couldn’t even install Brave through terminal so it is weird you are just not able to contact some brave servers for whatever reason.

Something is being blocked and unless you don’t fix that you can’t just use Brave as it was meant to be used.
I mean, at this point uBlock or even another browser with uBlock will be a better experience.